Bug 1293870 - User should be notified for wrong password in password reset page
Summary: User should be notified for wrong password in password reset page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
: 1333381 (view as bug list)
Depends On:
Blocks: 1309362
TreeView+ depends on / blocked
 
Reported: 2015-12-23 10:25 UTC by Abhijeet Kasurde
Modified: 2016-11-04 05:47 UTC (History)
7 users (show)

Fixed In Version: ipa-4.2.0-16.el7
Doc Type: Bug Fix
Doc Text:
Cause: Clearing of password fields after incorrect authentication started internal validation(success) which caused validator to clear all error messages - including the one sent by server. Consequence: Error message was hidden, user didn't know why the password change was unsuccessful. Fix: Error message is set after clearing the password fields. Result: User sees the error message sent by server.
Clone Of:
: 1309362 (view as bug list)
Environment:
Last Closed: 2016-11-04 05:47:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Abhijeet Kasurde 2015-12-23 10:25:16 UTC
Description of problem:

In WebUI, While resetting password in new user login page, if user enters wrong old password the password reset procedure fails. In WebUI, user does not get any warning message for wrong old password but in logs it shows error message 

"The old password or username is not correct" 

This behavior should be similar between WebUI and CLI.


Version-Release number of selected component (if applicable):
ipa-server-4.2.0-15.el7_2.3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create non admin user and set password in WebUI
2. Try to login with new non-admin user
3. UI will be redirected to password reset page
4. Enter wrong old password and New password 
5. Click "Reset password and login"

Actual results:
Nothing happens if you enter wrong old password.

Expected results:
User should be prompted with error message saying "Old password is wrong"

Comment 2 Petr Vobornik 2016-01-04 09:55:04 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5567

Comment 5 Petr Vobornik 2016-01-29 13:32:51 UTC
Has a potential to make life of enterprise IT departments difficult.

Comment 11 Petr Vobornik 2016-05-05 16:02:21 UTC
*** Bug 1333381 has been marked as a duplicate of this bug. ***

Comment 13 Sudhir Menon 2016-08-04 11:49:09 UTC
Fix is seen.
Verified using ipa-server-4.4.0-4.el7.x86_64

When incorrect old password is specified UI displays the message 'The password or username you entered is incorrect'

Comment 15 errata-xmlrpc 2016-11-04 05:47:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.