Bug 1293879 - The vnc guest name shows incorrect when connected by remote-viewer a connection file
The vnc guest name shows incorrect when connected by remote-viewer a connecti...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.3
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1293878
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 05:49 EST by mxie@redhat.com
Modified: 2016-11-03 21:13 EDT (History)
11 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293878
Environment:
Last Closed: 2016-11-03 21:13:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mxie@redhat.com 2015-12-23 05:49:44 EST
The bug also be reproduced on rhel7, so clone to rhel7

Version-Release number of selected component (if applicable):
virt-viewer-2.0-6.el7.x86_64

+++ This bug was initially created as a clone of Bug #1293878 +++

Description of problem:
The vnc guest name shows incorrect when connected by remote-viewer a connection file

Version-Release number of selected component (if applicable):
virt-viewer-2.0-9.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a vnc guest name "rhel6.7" and edit xml as below
 <graphics type='vnc' port='5901' autoport='no' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
 </graphics>

2.Start the vnc guest
#virsh start rhel6.7

3.Create an ini file,name "test.ini", format like following:
[virt-viewer]
type=vnc
host=localhost
port=5901

4.remote-viewer the connection file "test.ini" to connect the vnc guest 
#remote viewer test.ini

Actual results:
The vnc guest could be connected but guest's name shows the connection file's name, pls refer to screenshot1

Expected results:
The vnc guest could be connected and guest's name shows correct 

Addtional info:
The spice guest could show name correctly when connected by remote-viewer an connection file

Steps as below:
1.Prepare a spice guest name "2OS" and edit xml as below
 <graphics type='spice' port='5900' autoport='no' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
 </graphics>

2.Start the spice guest
#virsh start 2OS

3.Create an ini file,name "test.ini", format like following:
[virt-viewer]
type=spice
host=localhost
port=5900

4.remote-viewer the connection file "test.ini" to connect the spice guest and the spice guest shows name correctly, pls refer to screenshot2
#remote viewer test.ini

--- Additional comment from mxie@redhat.com on 2015-12-23 05:46 EST ---
Comment 2 Fabiano Fidêncio 2015-12-23 06:00:40 EST
Okay. It's already fixed upstream by this commit: 772698a8a6e34c0b5051a3519f9284313426c1ca (Set guest name when using VNC)
Also, for completeness, we most likely would like to have this commit as well: fc2add5827c359ced244c4e0a9cb36d24c24ee83 (Set uuid when using VNC)
Comment 6 xiaodwan 2016-04-15 02:06:03 EDT
I can reproduce it with virt-viewer-2.0-6.el7.x86_64.

Then updated virt-viewer to latest virt-viewer-2.0-7.el7.x86_64. The title displays correctly.

So move the bug from ON_QA to VERIFIED.
Comment 8 errata-xmlrpc 2016-11-03 21:13:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html

Note You need to log in before you can comment on or make changes to this bug.