Bug 1293887 - need HTTP_PROXY support for master to get ImageStream in container install
need HTTP_PROXY support for master to get ImageStream in container install
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Documentation (Show other bugs)
1.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Paul Weil
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 06:18 EST by Johnny Liu
Modified: 2017-05-31 14:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Paul Weil 2015-12-23 09:21:05 EST
Akram, if this is a dupe of 1293281 please close it with Mark as Duplicate
Comment 2 Johnny Liu 2015-12-23 21:29:00 EST
I do not think this is dup with 1293281, this is about container install (master service is running in a container), but 1293281 is about normal install (master process is running in OS).

And just like what is said in initial report, the same setting works well in released 3.1.0 release, this is our first time to test it in container install (container install was not supported yet when 3.1.0 is released).

More, 1293281 is a origin bug for new user story. I think they are different.
Comment 3 Akram Ben Aissi 2016-02-02 09:43:45 EST
can you give the command line used to launch OpenShift in a container ?
Do we specify the "-e" option with the adequate parameter:

docker run -d -e "HTTP_PROXY=full_proxy_url,HTTPS_PROXY=full_proxy_url" openshift/openshift-ose:latest  start
Comment 4 Akram Ben Aissi 2016-02-02 09:44:12 EST
can you give the command line used to launch OpenShift in a container ?
Do we specify the "-e" option with the adequate parameter:

docker run -d -e "HTTP_PROXY=full_proxy_url,HTTPS_PROXY=full_proxy_url" openshift/openshift-ose:latest  start
Comment 6 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.