Bug 1293891 - "Name" parameter does not work with category Collection for querying
"Name" parameter does not work with category Collection for querying
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API (Show other bugs)
5.5.0
x86_64 Linux
medium Severity high
: GA
: 5.6.0
Assigned To: Tim Wade
Taras Lehinevych
: ZStream
Depends On:
Blocks: 1302443
  Show dependency treegraph
 
Reported: 2015-12-23 07:04 EST by Prasad Mukhedkar
Modified: 2016-06-29 11:24 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1302443 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:24:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasad Mukhedkar 2015-12-23 07:04:53 EST
Description of problem:


Problem with API : Unable to filter the resources using name parameter 

/api/categories?expand=resources&filter[]=name='location'

if I execute above query we are getting following error 


{"error": {
   "kind": "internal_server_error",
   "message": "ERROR:  column classifications.name does not exist\nLINE 1: ...ns\" WHERE \"classifications\".\"parent_id\" = $1 AND (\"classific...\n                                                             ^\n",
   "klass": "PG::UndefinedColumn"
}}


Version-Release number of selected component (if applicable):


5.5.0.13.20151201120956_653c0d4


How reproducible:

always 

Actual results:
Error, Filtering does not work

Expected results:
Filtering should work and desired output should shown 

Additional info:



vmdb_production#select * from classification;

id           | 99000000000001
description  | Location
icon         | 
read_only    | f
syntax       | string
single_value | t
example_text | The geographic location of the resource, such as New York, Chicago, or London.
tag_id       | 99000000000004
parent_id    | 0
show         | t
default      | t
perf_by_tag  | 

"Name" column is not there in the table. Hence, The failure.
Comment 2 Tim Wade 2016-01-07 11:29:02 EST
PR: https://github.com/ManageIQ/manageiq/pull/6074
Comment 3 Taras Lehinevych 2016-04-08 09:40:43 EDT
Verified in 5.6.0.0-beta1.20160322143549_f7ea680
Comment 5 errata-xmlrpc 2016-06-29 11:24:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.