Bug 1293912 - [abrt] ModemManager-1.1.0-6.git20130913.el7: ModemManager killed by SIGABRT
[abrt] ModemManager-1.1.0-6.git20130913.el7: ModemManager killed by SIGABRT
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ModemManager (Show other bugs)
7.1
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Lubomir Rintel
Desktop QE
:
Depends On:
Blocks: 1203710 1301628 1313485
  Show dependency treegraph
 
Reported: 2015-12-23 08:38 EST by Deepu K S
Modified: 2016-11-04 04:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:31:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deepu K S 2015-12-23 08:38:58 EST
Description of problem:
ModemManager is crashing when probing if there are multiple ttyUSB* devices (ttyUSB0 and ttyUSB1 in this case). 
The driver used here is 'cp210x'. During the use of minicom application on /tty/USB0, ModemManager crash is displayed.

When minicom first starts up it seems that before modemmanager quits, we get a lot of gibberish from that tty.

ERROR:mm-port-probe.c:1289:mm_port_probe_run: assertion failed: (self->priv->task == NULL)

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Workstation release 7.1
ModemManager-1.1.0-6.git20130913.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Use of minicom program on /tty/USB0
2.
3.

Actual results:
ModemManager crash with below error.
ERROR:mm-port-probe.c:1289:mm_port_probe_run: assertion failed: (self->priv->task == NULL)

Expected results:
No crashes or errors.

Additional info:
ABT Server link : https://api.access.redhat.com/rs/telemetry/abrt/reports/bthash/671de6a93a6e76f8612c45a228276534a35db51c
Comment 5 Deepu K S 2015-12-23 08:51:08 EST
Blacklisting the device with '/lib/udev/rules.d/100-mm-usb-device-blacklist.rules' didn't work after which the device nodes (/dev/ttyUSB*) aren't created.

ACTION!="add|change", GOTO="mm_usb_device_blacklist_end"
SUBSYSTEM!="usb", GOTO="mm_usb_device_blacklist_end"
ENV{DEVTYPE}!="usb_device",  GOTO="mm_usb_device_blacklist_end"

ATTRS{idVendor}=="10c4", ATTRS{idProduct}=="ea70", ENV{ID_MM_DEVICE_IGNORE}="1"

LABEL="mm_usb_device_blacklist_end"
Comment 7 Lubomir Rintel 2016-03-31 10:57:18 EDT
The forced-close fix in fd1a1839ae1bcade2f9d422f6bc0d6e6040295e6 would avoid the repeated and unnecessary probes that lead to the crash.
Comment 10 errata-xmlrpc 2016-11-04 04:31:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2556.html

Note You need to log in before you can comment on or make changes to this bug.