Bug 1293915 - SMB:Samba shares not accessible from windows client and Linux cifs client
SMB:Samba shares not accessible from windows client and Linux cifs client
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: RHGS 3.1.2
Assigned To: rhs-smb@redhat.com
surabhi
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 08:53 EST by surabhi
Modified: 2016-03-01 01:10 EST (History)
9 users (show)

See Also:
Fixed In Version: 4.2.4-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:10:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 11647 None None None 2015-12-23 14:41 EST

  None (edit)
Description surabhi 2015-12-23 08:53:43 EST
Description of problem:
*********************************
After upgrading the systems to latest samba and gluster builds the samba shares
are not accessible from windows client and linux cifs client.

Version-Release number of selected component (if applicable):
samba-4.2.4-11.el7rhgs.x86_64
glusterfs-3.7.5-13.el7rhgs.x86_64

How reproducible:
Always 

Steps to Reproduce:
1.Upgrade the setups from previous version of samba and gluster
2.Mount the volume via cifs client or access the share from windows client
3.

Actual results:
Mount /access share on windows and Linux cifs client fails.


Expected results:
Mount of volume / access to samba share should succeed.


Additional info:
Comment 2 Michael Adam 2015-12-23 16:35:56 EST
Upstream patch exists.
It is tested in downstream with scratch build
https://brewweb.devel.redhat.com/taskinfo?taskID=10272563
from branch private-obnox-rhgs-3.1-rhel-6.

Patch is reviewed upstream and on its way to master upstream.
Will continue with upstream release branches in upstream BZ
and final downstream packaging.
Comment 5 surabhi 2015-12-28 08:35:30 EST
Updated the build on both RHEL6 and RHEL7 :

1.Executed mount from Linux cifs client and accessed the share , mount successfull.
2. Accessed the samba share from Windows client, and the access is successfull.
3. Tried with AD User on a CTDB VIP, the access to share is successfull.

Currently running sanity on both the systems.Will update the BZ soon with the results.
Comment 6 surabhi 2015-12-29 06:08:49 EST
The sanity passed on both RHEL6 and RHEL7 with the latest builds as follows :

RHEL6 : samba-4.2.4-12.el6rhs.x86_64.rpm  
RHEL7 : samba-4.2.4-12.el7rhgs.x86_64.rpm

Mount of Volume is successfull on cifs client.
Access to the samba share from windows client is successfull.
Ran Basic I/O 's (Create dirs,files,deep dirs,renames,deletes on Linux cifs client and windows share)successfull.
Also verified with subdirectory mounts and I/O's on the same.
Marking the BZ verified.
Comment 8 errata-xmlrpc 2016-03-01 01:10:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0326.html

Note You need to log in before you can comment on or make changes to this bug.