Bug 129393 - Genromfs uses getopt() improperly
Genromfs uses getopt() improperly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: genromfs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-07 15:58 EDT by W. Michael Petullo
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.5.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 06:31:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2004-08-07 15:58:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7)
Gecko/20040625 Epiphany/1.2.6

Description of problem:
Genromfs does not execute properly on my PowerPC-based system.  The
getopt function returns an int.  However, in genromfs.c the value
returned by getopt is assigned to a variable of type char.

Changing "char c;" to "int c;" fixes things.

Version-Release number of selected component (if applicable):
genromfs-0.3-17

How reproducible:
Always

Steps to Reproduce:
Try to run genromfs and notice that it does not execute properly. 
Further inspection determines that the problem is in genromfs's option
parsing code.
    

Additional info:

Triage->EasyFix
Comment 1 Jakub Jelinek 2004-09-01 06:31:24 EDT
Fixed by upgrading to 0.5.1.

Note You need to log in before you can comment on or make changes to this bug.