Bug 1293932 - [Tiering]: When files are heated continuously, promotions are too aggressive that it promotes files way beyond high water mark
[Tiering]: When files are heated continuously, promotions are too aggressive ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
: ZStream
Depends On: 1291969
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 10:10 EST by Dan Lambright
Modified: 2016-06-16 08:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1291969
Environment:
Last Closed: 2016-06-16 08:31:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-28 10:16:50 EST
REVIEW: http://review.gluster.org/13103 (cluster/tier: check watermark during migration) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 2 Vijay Bellur 2015-12-30 11:34:00 EST
REVIEW: http://review.gluster.org/13103 (cluster/tier: check watermark during migration) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 3 Vijay Bellur 2016-01-04 09:52:51 EST
REVIEW: http://review.gluster.org/13103 (cluster/tier: check watermark during migration) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 4 Vijay Bellur 2016-01-05 07:25:35 EST
COMMIT: http://review.gluster.org/13103 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 57ef73821c8062e1503926751fd72bdad7506c86
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Mon Dec 28 10:13:30 2015 -0500

    cluster/tier: check watermark during migration
    
    Currently we check the watermarks only before a cycle
    begins. We should also check the hot tier's fullness
    against the watermarks during the migration so the watermark
    is not exceeded as files are promoted.
    
    Change-Id: I2ff87a1c308d64fbdca14bbdf55f3ec3007290ae
    BUG: 1293932
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/13103
    Reviewed-by: Joseph Fernandes
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
Comment 5 Niels de Vos 2016-06-16 08:31:57 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.