Bug 1293944 - Log common locking management actions
Log common locking management actions
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Moti Asayag
Pavol Brilla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 10:53 EST by Moti Asayag
Modified: 2016-07-26 06:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-26 06:59:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
masayag: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51349 master MERGED core: Print lock acquire message during command execution 2016-01-05 07:42 EST

  None (edit)
Description Moti Asayag 2015-12-23 10:53:25 EST
Description of problem:
In certain flows (i.e. acquiring wait-lock in command execution), there is no logging in INFO level to complete the overall tracking after a specific lock.

How reproducible:
always

Steps to Reproduce:
1. Run command which requires wait-lock for its execution scope, i.e. deactivate storage domain.

Actual results:
notice no message in engine.log for the acquired lock.

Expected results:
A message for acquiring lock for the specific storage pool.

Additional info:
See CommandBase.acquireLockAndWait() which unlike CommandBase.acquireLockInternal() doesn't report lock acquire result.
Comment 1 Red Hat Bugzilla Rules Engine 2015-12-23 10:55:24 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Lukas Svaty 2016-07-26 06:59:49 EDT
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.