Bug 1293958 - [SFCI] Packstack allinone without demo failed with cinder type-create iscsi returned 1 instead of one of [0]
[SFCI] Packstack allinone without demo failed with cinder type-create iscsi r...
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
Kilo
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Kilo
Assigned To: Martin Magr
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 12:21 EST by Tristan Cacqueray
Modified: 2016-04-18 03:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-23 17:43:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tristan Cacqueray 2015-12-23 12:21:33 EST
Description of problem:
Since Dec23, packstack --allinone failed with:

192.168.0.164_cinder.pp:                          [ [0;31mERROR[0m ]
Applying Puppet manifests                         [ [0;31mERROR[0m ]

[0;31mERROR : Error appeared during Puppet run: 192.168.0.164_cinder.pp
Error: cinder type-create iscsi returned 1 instead of one of [0][0m
You will find full trace in log /var/tmp/packstack/20151223-165310-Lw1D16/manifests/192.168.0.164_cinder.pp.log

Version-Release number of selected component (if applicable):


How reproducible:

The RDO release: https://repos.fedorapeople.org/repos/openstack/openstack-kilo/rdo-release-kilo-1.noarch.rpm
The Packstack command line: sudo packstack --allinone --os-swift-install=y --os-ceilometer-install=n --nagios-install=n --provision-demo=n --keystone-admin-passwd=sf4ever --os-heat-install=y --cinder-volumes-size=50G

Steps to Reproduce:
You can currently observe that bug in this job: http://softwarefactory-project.io/jenkins/job/sf-openstack-kilo-1node-allinone/
starting with build #182

Actual results:
Packstack fail to deploy

Expected results:
Packstack succeed to deploy

Additional info:
We hit that bug in software factory project CI (thus the sfci Keywords).
Two jobs are testing OpenStack integration with the SF project using RDO release and packstack deployment:
  sf-openstack-kilo-1node-allinone and sf-openstack-liberty-1node-allinone.
The two jobs are identique, except that one will use rdo release, the other kilo release.
Comment 1 Tristan Cacqueray 2015-12-23 17:43:59 EST
The issue dissappeared by the time system logs debug was added to the job...
Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.