Bug 1293960 - [RFE] Control policy.json and schedule.json changes from ansible for all masters in HA setup
[RFE] Control policy.json and schedule.json changes from ansible for all mast...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Jason DeTiberus
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 12:33 EST by Ryan Howe
Modified: 2016-07-03 20:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 12:37:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-12-23 12:33:14 EST
Description of problem:
-Looking for the ability to control all needed configs that change in /etc/origin/master/* via ansible. 

Example would be having ansible control all changes made to the scheduler. 


Version-Release number of selected component (if applicable):
OSE 3.1 


Additional info:
- Also changes made in /etc/sysconfig would be nice if ansible could control
Comment 1 Brenton Leanhardt 2016-01-05 11:13:11 EST
Would it be helpful in the short term to product admins a way to specify a custom configuration file so that they could control these files themselves?

Alternatively, if you provide a prioritized list of fixes we can address them in order.
Comment 3 Jason DeTiberus 2016-04-04 17:34:34 EDT
The scheduler config has been addressed in https://github.com/openshift/openshift-ansible/pull/1680

It doesn't really make sense to support modifying the policy config on disk since it is only loaded if the policy doesn't already exist in etcd.
Comment 4 Ma xiaoqiang 2016-04-05 05:10:27 EDT
check on openshift-ansible -b master

scenarios 1:
Install env without 'openshift_master_scheduler_predicates' and 'openshift_master_scheduler_priorities'

check the configuration file, compare with the configuration from template,
the "ServiceSpreadingPriority" is changed to 'SelectorSpreadPriority', is it by design?


scenarios 2:
Install ha-master env with 'openshift_master_scheduler_predicates' and 'openshift_master_scheduler_priorities'
<--snip-->
openshift_master_scheduler_predicates=[{"name": "MatchNodeSelector"}, {"name": "PodFitsResources"}, {"name": "PodFitsPorts"}, {"name": "NoDiskConflict"}, {"name" : "MaxEBSVolumeCount"}]
openshift_master_scheduler_priorities=[{"name": "LeastRequestedPriority", "weight": 1}, {"name": "ServiceSpreadingPriority", "weight": 1}]
<--snip-->

check the configuration file after installation, the specified value take effect.

For the first scenario, if the change is by design, QE will move this issue to VERIFIED.
Comment 5 Jason DeTiberus 2016-04-05 22:22:30 EDT
Yes, the change from ServiceSpreadingPriority to SelectorSpreadPriority was to address the following Github Issue: https://github.com/openshift/openshift-ansible/issues/476
Comment 7 errata-xmlrpc 2016-05-12 12:37:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1065

Note You need to log in before you can comment on or make changes to this bug.