Bug 1293983 - [UX] show skipped packages during upgrade with pkg param
[UX] show skipped packages during upgrade with pkg param
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 16:50 EST by Adam Miller
Modified: 2017-06-09 15:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: dnf-2.5.0-2.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-09 15:06:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Miller 2015-12-23 16:50:51 EST
[root@maxamillion-osbs ~]# rpm -q atomic-reactor
atomic-reactor-1.6.0-2.fc24.noarch

[root@maxamillion-osbs ~]# dnf info atomic-reactor
Last metadata expiration check performed 0:07:10 ago on Wed Dec 23 21:40:19 2015.
Installed Packages
Name        : atomic-reactor
Arch        : noarch
Epoch       : 0
Version     : 1.6.0
Release     : 2.fc24
Size        : 10 k
Repo        : @System
From repo   : rawhide
Summary     : Improved builder for Docker images
URL         : https://github.com/projectatomic/atomic-reactor
License     : BSD
Description : Simple Python tool with command line interface for building Docker
            : images. It contains a lot of helpful functions which you would
            : probably implement if you started hooking Docker into your
            : infrastructure.

Available Packages
Name        : atomic-reactor
Arch        : noarch
Epoch       : 0
Version     : 1.6.0
Release     : 4.1.git.0.9c4344d.fc24
Size        : 17 k
Repo        : maxamillion-atomic-reactor
Summary     : Improved builder for Docker images
URL         : https://github.com/projectatomic/atomic-reactor
License     : BSD
Description : Simple Python tool with command line interface for building Docker
            : images. It contains a lot of helpful functions which you would
            : probably implement if you started hooking Docker into your
            : infrastructure.

Name        : atomic-reactor
Arch        : src
Epoch       : 0
Version     : 1.6.0
Release     : 4.1.git.0.9c4344d.fc24
Size        : 142 k
Repo        : maxamillion-atomic-reactor
Summary     : Improved builder for Docker images
URL         : https://github.com/projectatomic/atomic-reactor
License     : BSD
Description : Simple Python tool with command line interface for building Docker
            : images. It contains a lot of helpful functions which you would
            : probably implement if you started hooking Docker into your
            : infrastructure.

[root@maxamillion-osbs ~]# rpmdev-vercmp 1.6.0-2.fc24 1.6.0-4.1.git.0.9c4344d.fc24
1.6.0-2.fc24 < 1.6.0-4.1.git.0.9c4344d.fc24

[root@maxamillion-osbs ~]# rpm -q atomic-reactor
atomic-reactor-1.6.0-2.fc24.noarch

[root@maxamillion-osbs ~]# dnf update atomic-reactor --refresh
Copr repo for atomic-reactor owned by maxamillion                                       87 kB/s |  35 kB     00:00
Last metadata expiration check performed 0:00:00 ago on Wed Dec 23 21:47:52 2015.
Dependencies resolved.
Nothing to do.
Complete!

[root@maxamillion-osbs ~]# rpm -q dnf
dnf-1.1.5-1.fc24.noarch
Comment 1 Adam Miller 2015-12-23 17:21:24 EST
This turns out to be because a dependency was missing for the update. I still think it's a bug since dnf silently exited successfully.

# dnf install https://copr-be.cloud.fedoraproject.org/results/maxamillion/atomic-reactor/fedor
a-rawhide-x86_64/00149886-atomic-reactor/atomic-reactor-1.6.0-4.1.git.0.9c4344d.fc24.noarch.rpm
Last metadata expiration check performed 0:06:09 ago on Wed Dec 23 21:47:52 2015.
Error: nothing provides python3-docker-scripts >= 0.4.4 needed by python3-atomic-reactor-1.6.0-4.1.git.0.9c4344d.fc24.n
oarch
(try to add '--allowerasing' to command line to replace conflicting packages)
Comment 2 Jan Kurik 2016-02-24 09:10:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Fedora Admin XMLRPC Client 2016-07-08 05:32:02 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Jaroslav Mracek 2017-04-10 11:17:27 EDT
I create huge refactor of problems report https://github.com/rpm-software-management/dnf/pull/782. Hope that it helps. It provides information about conflict or broken dependency like you use --best.
Comment 5 Fedora Update System 2017-05-22 08:41:00 EDT
dnf-plugins-extras-2.0.1-1.fc26 dnf-plugins-core-2.1.0-1.fc26 libdnf-0.9.0-1.fc26 dnf-2.5.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-92e5a01da8
Comment 6 Fedora Update System 2017-05-22 12:40:07 EDT
dnf-2.5.0-1.fc26, dnf-plugins-core-2.1.0-1.fc26, dnf-plugins-extras-2.0.1-1.fc26, libdnf-0.9.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-92e5a01da8
Comment 7 Fedora Update System 2017-05-24 04:32:06 EDT
dnf-2.5.0-1.fc26 dnf-plugins-core-2.1.0-1.fc26 dnf-plugins-extras-2.0.1-1.fc26 dnfdaemon-0.3.17-3.fc26 libdnf-0.9.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-92e5a01da8
Comment 8 Fedora Update System 2017-05-24 10:33:11 EDT
dnf-2.5.0-2.fc26 dnf-plugins-core-2.1.0-1.fc26 dnf-plugins-extras-2.0.1-1.fc26 dnfdaemon-0.3.18-1.fc26 libdnf-0.9.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-92e5a01da8
Comment 9 Fedora Update System 2017-05-25 15:17:39 EDT
dnf-2.5.0-2.fc26, dnf-plugins-core-2.1.0-1.fc26, dnf-plugins-extras-2.0.1-1.fc26, dnfdaemon-0.3.18-2.fc26, libdnf-0.9.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-92e5a01da8
Comment 10 Fedora Update System 2017-06-09 15:06:15 EDT
dnf-2.5.0-2.fc26, dnf-plugins-core-2.1.0-1.fc26, dnf-plugins-extras-2.0.1-1.fc26, dnfdaemon-0.3.18-2.fc26, libdnf-0.9.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.