Bug 129401 - Draw: Using Stylist (no individual styles, cpu load, flickering)
Draw: Using Stylist (no individual styles, cpu load, flickering)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-07 17:59 EDT by Christoph Noack
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-25 15:45:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Noack 2004-08-07 17:59:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.4

Description of problem:
If you want to create a new (custon) style in the Stylist or using
Format -> Styles -> Catalogue... -> New... the text content of the
Stylist begins to flicker at about 10 Hz. During this time the CPU
load on my computer (P4mobile, 2GHz) raises from 20% to 40% (Gnome
System Monitor). From this time the new created style cannot be
selected, therefore not deleted or edited using the stylist. If you
delete the style using the Format -> Styles -> Catalogue... -> Delete
menu the flickering stops and the system load remains at 20%.

Loading previous created graphics causes also the flickering and the
high CPU load. These drawings were created using OOo 1.0.3 to 1.1.1
(from several Linux Distributors or downloaded form the OOo project
directly).

The funny thing is (according to the OOo website) that Draw and
Impress are mainly based on the same code. In Impress these problems
do not occur.

Using the Stylist in Impress has two modes: graphic object styles and
presentation object styles. Therefore both icons above the textbox are
shown. Normally in OOo Draw (as I remember from previous versions of
OOo) the right icon containing the presentation object styles is
deactivated (and grayed). Therefore the style mode can't be changed.
Here the icon is active and can be selected - for a short period of 
time you can see the presentation object styles in Draw. Then the mode
switches back to graphic object styles.

The icon of the watering can in Draw's Stylist flickers the whole time.

Another problem: Editing text in Draw (not Impress) causes CPU load to
rise on 40%. Some icons of the format icon bar beginn to flicker
(approx. 10 Hz): Left Alignment to Numbering on/off (=10 icons).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start OpenOffice.org Draw OR create an new OpenOffice.org Draw
Document
2. Open Stylist. Right click on any style and select "New..."
3. Confirm the dialog (it's not necessary to change any settings).
-> The text begins to flicker.  

Actual Results:  Text in textbox flickers.
Custom styles cannot be selected (deleted, edited) using Stylist.
"Presentation object styles" can be selected, but do not work.
High CPU load.
Flickering of on symbol in the stylist the whole time.

Expected Results:  Stylist should behave like in OOo Impress.

Additional info:

* I've tested it on two personal computers running Fedora Core 2
(OpenOffice.org 1.1.1). This error occured on both PCs. All updates
have been applied.
* I'm using german language on my computer, so I hope I've used the
correct terms to describe the problem.
Comment 1 Nicu Buculei 2004-09-14 09:12:33 EDT
i can see the same problem using openoffice.org-1.1.1-6
Comment 2 Linda Worthington 2004-09-14 14:57:14 EDT
I have the same problem using OpenOffice.org-1.1.1 on Fedora C2.
Comment 3 Dan Williams 2004-09-18 11:34:12 EDT
cannot reproduce with what will be come 1.1.2-5, look for it soon.
Comment 4 Ben Van den Brande 2004-09-22 05:02:11 EDT
Problem still persist in FC3 test2 OOo 1.1.2
Comment 5 Nicu Buculei 2004-09-22 05:11:33 EDT
Ben, as Dan said in comment #3 he can't reproduce it 1.1.2-5, FC3T2
contains 1.1.2-3. 
1.1.2-5 should be soon in Rawhide, you may want to test that
Comment 6 Linda Worthington 2004-09-22 05:14:54 EDT
Is there going to be an update for Fedora C2?
Comment 7 Dan Williams 2004-09-22 05:23:32 EDT
Yes, I hope to be able to get a 1.1.2-5 for FC2 and FC1 when its done
for FC3.  ATM, we are dying on x86 due to changes in glibc that expose
a bug in OO's core tools, causing a tool to crash during the build
process.
Comment 8 Dan Williams 2004-09-25 15:45:07 EDT
Please test with the openoffice.org-1.1.2-5 RPMs in Rawhide, it should
be fixed in that version.  If the problem persists with that version,
please reopen this bug.  Thanks!
Comment 9 Ben Van den Brande 2004-09-27 07:41:39 EDT
Problem still persists in 1.1.2-6

Ben
Comment 10 Ben Van den Brande 2004-09-28 10:03:42 EDT
When the flickering occurs (stylist active), the CPU usage of the
"metacity" process jumps to 13-14%. Without the stylist active the CPU
usage is 0-1%. 

Note You need to log in before you can comment on or make changes to this bug.