Bug 129403 - Can't compile with kernel source due to missing 686 links
Summary: Can't compile with kernel source due to missing 686 links
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-07 23:55 UTC by Bertil Askelid
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-09 11:44:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bertil Askelid 2004-08-07 23:55:18 UTC
Description of problem:

In the following places there needs to be soft links added to allow
for compilation on an i686 architecture:

/usr/src/linux-*/arch/i686 -> <same dir>i386
/lib/modules/{build,kernel}/arch/i686 -> <same dir>/i386

Version-Release number of selected component (if applicable):

2.6.7-1.494.2.2

How reproducible:

always

Steps to Reproduce:
1.compile something against the running kernel source, like vmware
2.
3.
  
Actual results:

compilation fails due to not finding 'i686' directory

Expected results:

compile

Additional info:

Comment 1 Arjan van de Ven 2004-08-08 07:56:16 UTC
this can only mean that the makefile for the program in question is
really broken.

(in addition usr/src/linux-*/ can't be used for building modules
against the kernel)


Note You need to log in before you can comment on or make changes to this bug.