Bug 129406 - Annaconda fails to fully update all component yet update is sucsesful
Annaconda fails to fully update all component yet update is sucsesful
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-08 03:08 EDT by Nial
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 15:46:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nial 2004-08-08 03:08:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040616

Description of problem:
Version: fedora core 2
kernle: 2.6.5-1.386
components: SE Linux, Annaconda, Kile

Problem: 
Updating from fedora core 1 to fedora core 2. This part has no proble
that is aparent wilst the updata runs. The issues arises once all this
has completed and new ( not apart of the fedora release ) source code
are installed.

What seems to happen is that only parts of SE Linux are installed. So
when you try to install another aplication ( eg kile ) that may use SE
Linux it is unable to link properly and or find components.

It is worth noting that reinstalling from scrach seem to void this
problem.

Suspisions:
As best i can tell, the problem lies in Annaconda. When Annaconda
serches for what needs to be updataed it faile to relise that it
should also install all the part from SE linux.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Didn't try

Steps to Reproduce:
1.install all components of fedora core 1
2.update to fedora core 2
3.try to install soming like Kile from source
    

Additional info:
Comment 1 Jeremy Katz 2004-08-10 15:46:02 EDT
Build dependencies of kile are missing the appropriate dependencies on
libselinux-devel.  Without knowing more about kile, I can't say what
those packages are.  Track down which of the libraries kile is linking
with require libselinux and then file bugs against those packages for
their -devel missing a Requires:

Note You need to log in before you can comment on or make changes to this bug.