Bug 1294071 - An attached disk appears power down but the VM is using it
An attached disk appears power down but the VM is using it
Status: CLOSED DUPLICATE of bug 1044466
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.4
Unspecified Unspecified
high Severity high
: ovirt-3.6.5
: 4.0.3
Assigned To: Amit Aviram
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-24 07:13 EST by Sarvesh Pandit
Modified: 2016-03-10 05:28 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-24 08:12:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2107461 None None None 2015-12-24 08:23 EST

  None (edit)
Description Sarvesh Pandit 2015-12-24 07:13:10 EST
Description of problem:

An attached disk appears power down but the VM is using it and seen as ok, We have checked in DB and found to be active and used.

Version-Release number of selected component (if applicable):


How reproducible:
NA

Steps to Reproduce:
NA

Actual results:
Disk status as Power Down

Expected results:
Disk Status should be UP

Additional info:
Comment 5 Tal Nisan 2016-01-03 07:40:06 EST
Given the timeline it will not make it to 3.6.2, deferring to 3.6.5 until we get an answer in late January
Comment 6 Allon Mureinik 2016-01-03 08:06:53 EST
If the disk appears properly in the DB, doesn't a simple refresh of the GUI solve the issue?
Comment 8 Kevin Alon Goldblatt 2016-01-06 05:56:16 EST
Hi Sarvesh, 
Can you elaborate the steps to reproduce this. Does this happen to all attached disks? Does this happen the moment you attach the disks and start the VM or after a specific event?
Comment 11 Allon Mureinik 2016-01-10 09:30:09 EST
(In reply to Allon Mureinik from comment #6)
> If the disk appears properly in the DB, doesn't a simple refresh of the GUI
> solve the issue?

Sarvesh, can you answer this question please?
Comment 17 Amit Aviram 2016-01-24 08:12:02 EST
This bug is probably a duplication of Bug 1044466 which was solved in 3.5.6. The bug is basically a faulted hotunplug at the host side, which reported a success back to the engine. in that case, the disk looks unplugged at the engine while it is actually still attached to the VM.

Currently we will close the as duplicate- if the issue persists after upgrading to 3.5.6, please reopen.

*** This bug has been marked as a duplicate of bug 1044466 ***

Note You need to log in before you can comment on or make changes to this bug.