Bug 1294073 - [tiering]: Incorrect display of 'gluster v tier help'
[tiering]: Incorrect display of 'gluster v tier help'
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
high Severity medium
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
Sweta Anandpara
: Regression, ZStream
Depends On:
Blocks: 1294448 1294942
  Show dependency treegraph
 
Reported: 2015-12-24 07:25 EST by Sweta Anandpara
Modified: 2016-09-17 11:43 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1294448 (view as bug list)
Environment:
Last Closed: 2016-03-01 01:05:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sweta Anandpara 2015-12-24 07:25:05 EST
Description of problem:

Two 'gluster v tier' commands end up in the same line, in the help output. This is seen in the latest build glusterfs-3.7.5-13.el7rhgs.x86_64s, and not in the older builds.

Version-Release number of selected component (if applicable):
glusterfs-3.7.5-13.el7rhgs.x86_64s

How reproducible: Always


Steps to Reproduce:
1. Type 'gluster v tier help'
            OR
1. Type 'gluster v tier' <enter>


Actual results:

Usage: volume tier <VOLNAME> status
volume tier <VOLNAME> start [force]volume tier <VOLNAME> attach [<replica COUNT>] <NEW-BRICK>...
volume tier <VOLNAME> detach <start|stop|status|commit|[force]>


Expected results:

Usage: volume tier <VOLNAME> status
volume tier <VOLNAME> start [force]
volume tier <VOLNAME> attach [<replica COUNT>] <NEW-BRICK>...
volume tier <VOLNAME> detach <start|stop|status|commit|[force]>
Comment 4 Sweta Anandpara 2016-01-07 00:10:08 EST
Tested and verified this on the build glusterfs-3.7.5-14.el7rhgs.x86_64

No syntactic/semantic errors seen in 'man gluster' and 'gluster v tier help'. Pasted below are the complete logs. Moving this bug to fixed in 3.1.2

[root@dhcp42-58 ~]# gluster v tier
Usage: volume tier <VOLNAME> status
volume tier <VOLNAME> start [force]
volume tier <VOLNAME> attach [<replica COUNT>] <NEW-BRICK>...
volume tier <VOLNAME> detach <start|stop|status|commit|[force]>

Tier command failed
[root@dhcp42-58 ~]# man gluster
[root@dhcp42-58 ~]# man gluster v tier
No manual entry for v
No manual entry for tier
[root@dhcp42-58 ~]# 
[root@dhcp42-58 ~]# 
[root@dhcp42-58 ~]# man gluster volume tier
No manual entry for volume
No manual entry for tier
[root@dhcp42-58 ~]# gluster v tier help
Usage: volume tier <VOLNAME> status
volume tier <VOLNAME> start [force]
volume tier <VOLNAME> attach [<replica COUNT>] <NEW-BRICK>...
volume tier <VOLNAME> detach <start|stop|status|commit|[force]>

[root@dhcp42-58 ~]# rpm -qa | grep gluster
glusterfs-api-3.7.5-14.el7rhgs.x86_64
glusterfs-devel-3.7.5-14.el7rhgs.x86_64
glusterfs-debuginfo-3.7.5-14.el7rhgs.x86_64
glusterfs-libs-3.7.5-14.el7rhgs.x86_64
glusterfs-client-xlators-3.7.5-14.el7rhgs.x86_64
glusterfs-fuse-3.7.5-14.el7rhgs.x86_64
glusterfs-server-3.7.5-14.el7rhgs.x86_64
glusterfs-api-devel-3.7.5-14.el7rhgs.x86_64
glusterfs-rdma-3.7.5-14.el7rhgs.x86_64
glusterfs-3.7.5-14.el7rhgs.x86_64
glusterfs-cli-3.7.5-14.el7rhgs.x86_64
glusterfs-geo-replication-3.7.5-14.el7rhgs.x86_64
[root@dhcp42-58 ~]#
Comment 6 errata-xmlrpc 2016-03-01 01:05:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.