Bug 129411 - Newer compat-db provides a db4 version without an explicit Provides
Newer compat-db provides a db4 version without an explicit Provides
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Depends On:
  Show dependency treegraph
Reported: 2004-08-08 10:56 EDT by Jeff Pitman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-10 05:33:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Pitman 2004-08-08 10:56:04 EDT
Compiling compat-db 4.1.25 on FC1 and then trying to install it causes
apt/yum to remove pam because pam has a db4 = 4.1.25 dependency.

Version-Release number of selected component (if applicable):


Steps to Reproduce:
1. Grab compat-db from FC2.
2. mach -r fc1 build compat-db.spec
3. mach -r fc1 apt-get install compat-db


Insert a Provides: db4 = 4.1.25 inside of compat-db.spec to make pam

Maybe I should file against pam for putting db4 = 4.1.25, Redhat 9 did
not have a problem compiling compat-db 4.1.25-2.1 because pam required
the library libdb-4.0.so and not the package itself.

Anyway, something fishy is happening, but the Provides: hack works in
the interim.
Comment 1 Jeff Johnson 2004-08-09 09:49:05 EDT
Pam should do
   Requires: libddb-4.1.so
rather than
   Requires: db4 = 4.1.25
so that the requirement can be satisfied by either
db4 or compat-db.

Adding an additional Provides: to compat-db is likely
to confuse the issue further.
Comment 2 Tomas Mraz 2005-01-14 11:45:18 EST
Hmm... the question is how the format of the db files change. See this
comment in pam.spec:
# We internalize libdb to get a non-threaded copy, but we should at
least try
# to coexist with the system's copy of libdb, which will be used to
make the
# files for use by pam_userdb (either by db_load or Perl's DB_File

It means that the only reason of the Requires in the pam package is
compatibility of the database files created. What db versions are file
Comment 3 Tomas Mraz 2005-02-10 05:33:52 EST
As pam doesn't really require libdb to be functional there is now
rather Conflict: db4 >= 4.4.0 in the devel pam.

Note You need to log in before you can comment on or make changes to this bug.