Bug 1294128 - file /usr/lib/systemd/system/blk-availability.service from install of device-mapper-7:1.02.107-5.el7.x86_64 conflicts with file from package lvm2-7:2.02.105-14.el7.x86_64
file /usr/lib/systemd/system/blk-availability.service from install of device-...
Status: CLOSED DUPLICATE of bug 1325394
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.2
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Peter Rajnoha
cluster-qe@redhat.com
:
Depends On:
Blocks: 1313485 1295577
  Show dependency treegraph
 
Reported: 2015-12-25 00:59 EST by Lakshmipathi
Modified: 2016-06-02 08:58 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-02 08:58:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lakshmipathi 2015-12-25 00:59:00 EST
Description of problem:

On centos-7 , sudo yum install libguestfs-tools fails with conflict errors



Version-Release number of selected component (if applicable):

 libguestfs-tools                                 noarch                  1:1.28.1-1.55.el7.centos                     base                     108 k

$ uname -a
Linux . 3.10.0-229.20.1.el7.x86_64 #1 SMP Tue Nov 3 19:10:07 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

everytime i hit this error

Steps to Reproduce:
1.yum install libguestfs-tools
2.
3.

Actual results:
Transaction check error:
  file /usr/lib/systemd/system/blk-availability.service from install of device-mapper-7:1.02.107-5.el7.x86_64 conflicts with file from package lvm2-7:2.02.105-14.el7.x86_64
  file /usr/sbin/blkdeactivate from install of device-mapper-7:1.02.107-5.el7.x86_64 conflicts with file from package lvm2-7:2.02.105-14.el7.x86_64
  file /usr/share/man/man8/blkdeactivate.8.gz from install of device-mapper-7:1.02.107-5.el7.x86_64 conflicts with file from package lvm2-7:2.02.105-14.el7.x86_64

Error Summary
-------------


Expected results:

there should be no error.

Additional info:
Comment 2 Peter Rajnoha 2016-01-06 08:13:28 EST
(In reply to Lakshmipathi from comment #0)
> Transaction check error:
>   file /usr/lib/systemd/system/blk-availability.service from install of
> device-mapper-7:1.02.107-5.el7.x86_64 conflicts with file from package
> lvm2-7:2.02.105-14.el7.x86_64
>   file /usr/sbin/blkdeactivate from install of
> device-mapper-7:1.02.107-5.el7.x86_64 conflicts with file from package
> lvm2-7:2.02.105-14.el7.x86_64
>   file /usr/share/man/man8/blkdeactivate.8.gz from install of
> device-mapper-7:1.02.107-5.el7.x86_64 conflicts with file from package
> lvm2-7:2.02.105-14.el7.x86_64

We've moved the blkdeactivate script and associated files from lvm2 to device-mapper package in RHEL 7.2 version of lvm2. The bug here is that if device-mapper *alone* is updated and not togethe with lvm2, then we end up with older lvm2 and newer device-mapper package and both having the blkdeactivate, hence the rpm transaction error.

This doesn't happen the other way round if lvm2 is updated first which brings in the newer device-mapper first - there's a proper dep here.

I need to add a condition to the device-mapper package's spec file to conflict with the older lvm2 (or something better if there's a way) so this situation as described here in this report does not happen.

For now, just update lvm2 package first, then everything should be working again.
Comment 3 Richard W.M. Jones 2016-01-06 08:26:13 EST
libguestfs Requires lvm2, but I think because it doesn't
require a specific version of lvm2, yum doesn't think it needs
to be upgraded.  Possibly something else (kernel?) is requiring
a newer version of device-mapper, so yum thinks it can satisfy
the libguestfs install just by upgrading device-mapper.

As Peter says, the workaround is to 'yum upgrade lvm2' first.
Comment 5 Lakshmipathi 2016-01-13 11:36:09 EST
Thanks for the info. After 'yum upgrade lvm2', libguestfs-tools  is installed.
Comment 6 Peter Rajnoha 2016-06-02 08:58:21 EDT

*** This bug has been marked as a duplicate of bug 1325394 ***

Note You need to log in before you can comment on or make changes to this bug.