Bug 1294164 - update for sqlite-3.9.2
update for sqlite-3.9.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spatialite-tools (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Volker Fröhlich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-25 02:28 EST by J. Randall Owens
Modified: 2016-01-07 22:21 EST (History)
2 users (show)

See Also:
Fixed In Version: spatialite-tools-4.3.0-5.fc23 spatialite-tools-4.2.0-17.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-05 16:55:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. Randall Owens 2015-12-25 02:28:51 EST
Description of problem:
spatialite-tools requires sqlite = 3.9.0, preventing sqlite upgrade

Version-Release number of selected component (if applicable):
spatialite-tools-4.3.0-4.fc23

How reproducible:
readily

Steps to Reproduce:
1. install spatialite-tools and old sqlite-3.9.0-1.fc23 (if you can find it)
2. dnf upgrade --best

Actual results:
Error: package spatialite-tools-4.3.0-4.fc23.x86_64 requires sqlite = 3.9.0, but none of the providers can be installed

Expected results:
upgrades sqlite

Additional info:
It looks like libspatialite & spatialite-gui just require libsqlite3.so.0(), so this shouldn't bite them too.
Comment 1 Fedora Update System 2015-12-28 07:08:17 EST
spatialite-tools-4.2.0-17.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-41cf042e9a
Comment 2 Volker Fröhlich 2015-12-28 07:10:07 EST
More important, spatialite-tools-4.3.0-5.fc23
Comment 3 Fedora Update System 2015-12-28 19:54:51 EST
spatialite-tools-4.3.0-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7677955390
Comment 4 Fedora Update System 2015-12-30 15:54:10 EST
spatialite-tools-4.2.0-17.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-41cf042e9a
Comment 5 Fedora Update System 2016-01-05 16:55:25 EST
spatialite-tools-4.3.0-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2016-01-07 22:21:21 EST
spatialite-tools-4.2.0-17.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.