Bug 129417 - dhclient should probably send option 61 by default
dhclient should probably send option 61 by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-08 13:31 EDT by Michael Cook
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-09 18:48:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Cook 2004-08-08 13:31:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040626 Firefox/0.8

Description of problem:
On my network, I usually have only one Linux client (along with a few
other non-Linux clients).

I noticed whenever I put two Fedora clients on my network, my DHCP
server would give them the same IP address.
Obviously, my DHCP server is broken.
But Fedora is the only operating system on my network that seems to be
affected by this bug.

And it turns out there's an easy change that makes Fedora not care
about this bug.

BTW, my DHCP server is the Motorola VT1000v device used by Vonage (it
appears to be running VxWorks).
So, it's likely there are a good amount of Fedora users who would see
this problem.

The fix is to have dhclient include DHCP Option 61 (client-identifier)
in the DHCP request.  For example:

For example:

# cat /etc/dhclient-eth0.conf
interface "eth0" {
	send dhcp-client-identifier 00:30:48:41:DE:E4;
}
#


Version-Release number of selected component (if applicable):
dhclient-3.0.1rc14-1

How reproducible:
Always

Steps to Reproduce:
1. Setup the Motorola VT1000v device to be your DHCP server.
2. Boot two or more Fedora hosts on your network.
3. Observe that all Fedora hosts are given the same IP address.
    

Actual Results:  See step 3.

Expected Results:  Each Fedora host should have been given a different
IP address.

Additional info:
Comment 1 Jason Vas Dias 2004-08-09 18:48:54 EDT
 99.9% of DHCP servers use the client's ethernet address as the
 "dhcp-client-identifier" automatically if no such option is supplied
 by the client.
 For abnormal DHCP servers, the /etc/dhclient-$if.conf script can
 supply non-standard options (no options are supplied by default),
 which you have been able to use to overcome your problem with this
 specific dhcp server .
 There is no way we could (or should) change the default behaviour,
 which works with 99.9% of dhcp servers, to always use this option -  
 that would prevent users from using other types of
 dhcp-client-identifier, especially as there is an easy workaround,
 which you found. 
 Try updating dhcp to dhcp-3.0.1, soon to be in FC2 updates (already
 in FC3 / rawhide).



  
Comment 2 John Flanagan 2004-12-21 14:41:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-566.html

Note You need to log in before you can comment on or make changes to this bug.