Bug 1294208 - [GTK3] [Xorg] Scrolling in LibreOffice bounces or go in reverse direction
[GTK3] [Xorg] Scrolling in LibreOffice bounces or go in reverse direction
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-25 07:49 EST by Anass Ahmed
Modified: 2016-02-14 21:51 EST (History)
8 users (show)

See Also:
Fixed In Version: libreoffice-5.0.5.1-3.fc23 libreoffice-5.0.5.2-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-14 21:51:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LibreOffice Writer Scrolling Bounces or goes to the opposite direction (1.81 MB, application/octet-stream)
2015-12-25 07:49 EST, Anass Ahmed
no flags Details
LibreOffice Writer VS Document Viewer (Evince) (4.48 MB, application/octet-stream)
2016-02-10 10:55 EST, Anass Ahmed
no flags Details

  None (edit)
Description Anass Ahmed 2015-12-25 07:49:34 EST
Created attachment 1109395 [details]
LibreOffice Writer Scrolling Bounces or goes to the opposite direction

Description of problem:
When I use LibreOffice writer or calc with a multi-pages document and I try to scroll down, it scrolls a little then bounces back again, and sometimes it doesn't go to the scrolling direction, it goes in reverse (always going to the top, I tried the opposite: to go the top so I can get to the bottom but this doesn't happen).

You may note also that the scrolling is interrupted by these bounces, so I can't scroll for a long time!

Scrolling using the scroll bar itself is working just fine.

Version-Release number of selected component (if applicable):
libreoffice-gtk3-5.0.4.2-3.fc23.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Open a document with multi-pages content in Writer.
2. Try to scroll down.
3. 

Actual results:
The scroll bar bounces back a little bit, or goes entirely in the opposite direction (always to top).

Expected results:
Scrolling down goes down without interruption.

Additional info:
This is the GTK3 version under Xorg.
Comment 1 Anass Ahmed 2015-12-25 08:07:16 EST
This issue happens under Wayland too but not the same. The reverse direction isn't under Wayland. The bounces are less and I can scroll a long time without bouncing. but the bouncing is still there.

I don't know the reason, but I'm guessing that LibreOffice is so sensitive for scrolling and maybe it detects a very small bounces of my touchpad, though this doesn't happen with other GTK3 apps like Firefox, GNOME Notes, GNOME Files... etc.
Comment 2 Caolan McNamara 2016-01-27 11:20:01 EST
Two finger scroll I guess. At least I see behaviour like that when using that mode.
Comment 3 Anass Ahmed 2016-01-27 16:00:13 EST
The issue occurs on both: Two finger scroll, and Edge scroll. I tried it now with the mouse scroll and it works as expected.

I've tried to use the updates-testing to download the new version of libreoffice-gtk but I couldn't find it. Waiting for it to be published.
Comment 4 Fedora Update System 2016-02-08 07:30:46 EST
libreoffice-5.0.5.1-7.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2fca765923
Comment 5 Fedora Update System 2016-02-09 17:27:22 EST
libreoffice-5.0.5.1-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2fca765923
Comment 6 Anass Ahmed 2016-02-10 10:37:32 EST
I've tried the last update on testing and yes, it has fixed the issue of going to the opposite direction of scrolling. but it's still has the a small bouncing when I stop scrolling.

The scrolling in general is not smooth in comparison to other GTK3 apps: Firefox and Document Viewer.

I'll attach a video for comparison between LibreOffice and Document Viewer (Evince).
Comment 7 Anass Ahmed 2016-02-10 10:55 EST
Created attachment 1122836 [details]
LibreOffice Writer VS Document Viewer (Evince)

This is a comparison between scrolling in LibreOffice Writer VS Document Viewer (Evince). Note that I use the same motion timing and distance but it differs in reaction. Note also that you will notice a small bounce when I stop scrolling in LibreOffice.

This is 2-finger touchpad motion, BTW.
Comment 8 Fedora Update System 2016-02-14 21:51:43 EST
libreoffice-5.0.5.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.