Bug 1294209 - glusterfs.spec.in: use %global per Fedora packaging guidelines
glusterfs.spec.in: use %global per Fedora packaging guidelines
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-25 07:56 EST by Kaleb KEITHLEY
Modified: 2016-06-16 09:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:52:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-12-25 07:56:40 EST
Description of problem:

use of %global is preferred over %define

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-12-25 08:18:50 EST
REVIEW: http://review.gluster.org/13079 (glusterfs.spec.in: use %global per Fedora pkg guidelines) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Vijay Bellur 2015-12-26 04:22:16 EST
COMMIT: http://review.gluster.org/13079 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 618f130ed0e653566db34878b36a2db34dcd6723
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Fri Dec 25 08:11:54 2015 -0500

    glusterfs.spec.in: use %global per Fedora pkg guidelines
    
    ref. recent emails in fedora-devel ml
    
    See:
      https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#.25global_preferred_over_.25define
    and the thread beginning at
      https://www.redhat.com/archives/fedora-packaging/2009-May/msg00095.html
    
    Also fix a couple instances of %if ... %else ... %endif indentation
    to be consistent with the rest of the .spec
    
    Change-Id: Iaf7332fd8601d78bc0d8249033cff12a452654bf
    BUG: 1294209
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13079
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:52:16 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.