Bug 1294230 - RFE powermock - Please build a package for EPEL7
RFE powermock - Please build a package for EPEL7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: powermock (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Roman Kennke
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On: 1294231 1294232
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-25 11:00 EST by Raphael Groner
Modified: 2017-06-11 21:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1294231 1294232 (view as bug list)
Environment:
Last Closed: 2017-06-11 21:33:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2015-12-25 11:00:50 EST
Description of problem:
There are packages for EPEL6 and 5. Please apply it also for EPEL7.

Version-Release number of selected component (if applicable):
-

How reproducible:
yes

Steps to Reproduce:
1. run an EPEL7 system
2. dnf install powermock
3.

Actual results:
no package found.

Expected results:
powermock gets installed with success.

Additional info:
DEBUG util.py:393:  Getting requirements for powermock-1.6.2-2.el7.src
DEBUG util.py:393:   --> maven-local-3.4.1-11.el7.noarch
DEBUG util.py:393:   --> apache-commons-logging-1.1.2-7.el7.noarch
DEBUG util.py:393:   --> tomcat-servlet-3.0-api-7.0.54-2.el7_1.noarch
DEBUG util.py:393:   --> junit-4.11-8.el7.noarch
DEBUG util.py:393:   --> cglib-2.2-18.el7.noarch
DEBUG util.py:393:   --> maven-plugin-bundle-2.3.7-12.el7.noarch
DEBUG util.py:393:   --> javassist-3.16.1-10.el7.noarch
DEBUG util.py:393:   --> mockito-1.9.0-19.el7.noarch
DEBUG util.py:393:   --> mockito-1.9.0-19.el7.noarch
DEBUG util.py:393:   --> objenesis-1.2-18.el7.noarch
DEBUG util.py:393:   --> sonatype-oss-parent-7-6.el7.noarch
DEBUG util.py:393:  Error: No Package found for mvn(cglib:cglib-nodep)
DEBUG util.py:393:  Error: No Package found for mvn(org.easymock:easymock)
Comment 1 Jan Kurik 2016-02-24 10:53:26 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Raphael Groner 2016-03-24 19:25:27 EDT
Hi Roman,
can you take this bug? I'm currently of less free time and would like to delay this request if possible.
Comment 3 Raphael Groner 2016-12-09 14:47:16 EST
Currently not possible to build in EPEL7:

DEBUG util.py:426:  Error: No Package found for mvn(cglib:cglib-nodep)
DEBUG util.py:426:  Error: No Package found for mvn(org.easymock:easymock)

Need to build cglib and easymock first.
Comment 4 Benjamin Lefoul 2017-04-28 03:03:44 EDT
The BR mvn(cglib:cglib-nodep) can simply be removed.

Rationale (in rawhide):

‹master›$ grep "cglib-nodep" cglib.spec
%pom_disable_module cglib-nodep
%mvn_alias :cglib "net.sf.cglib:cglib" "cglib:cglib-full" "cglib:cglib-nodep" "org.sonatype.sisu.inject:cglib"
- Add alias for cglib:cglib-nodep

On CentOS 7:

[root@localhost ~]# rpm -q --provides cglib
cglib = 2.2-18.el7
mvn(cglib:cglib) = 2.2
mvn(cglib:cglib-full) = 2.2
mvn(net.sf.cglib:cglib) = 2.2
osgi(net.sf.cglib.core) = 2.2

In EPEL7:

powermock ‹epel7›$ grep "net.sf.cglib:" powermock.spec
BuildRequires:  mvn(net.sf.cglib:cglib)



Conclusion:

Just remove this line:
BuildRequires:  mvn(cglib:cglib-nodep)


Now easymock has to be treated. Note: RHEL7 has already easymock-1.2-22.el7:
[root@localhost ~]# repoquery --provides easymock
easymock = 1.2-22.el7
mvn(easymock:easymock) = 1.2_Java1.5
Comment 5 Raphael Groner 2017-04-28 17:55:36 EDT
The current assumptions are wrong. It's more about the mvn($foo) magic not available in epel7:

DEBUG util.py:436:  Error: No Package found for mvn(cglib:cglib-nodep)
DEBUG util.py:436:  Error: No Package found for mvn(org.easymock:easymock)

powermock obviously needs cglib to can work due to the extended mockito is based on it, but propably without easymock as the powermock-api-easymock module is in a subpackage that could be skipped in epel7.

https://koji.fedoraproject.org/koji/taskinfo?taskID=19280793
Comment 6 Raphael Groner 2017-05-02 16:07:15 EDT
powermock needs easymock 3.x for the availability of the full API and we have easymock 1.x and easymock2 2.x in rhel7 but no package for 3.x yet. I failed to build from latest rawhide sources (for powermock 1.6.5) as well as from older fedora branches (f21 or f20 for powermock 1.4.12) and I don't have an interest for a compatibility package named easymock3 in epel7.

Closing here. Please feel free to open a new bug if you still think we need a package in epel7.
Comment 8 Benjamin Lefoul 2017-05-05 14:40:56 EDT
(In reply to Raphael Groner from comment #7)
> https://git.centos.org/summary/rpms!rh-java-common-easymock3

What is this? Is it the SCL?

Note that easymock3 already exists and I have the EPEL7 commit and ACLs:

https://admin.fedoraproject.org/pkgdb/package/rpms/easymock3/

What are you recommending?
Comment 9 Raphael Groner 2017-05-07 17:14:18 EDT
(In reply to Benjamin Lefoul from comment #8)
> (In reply to Raphael Groner from comment #7)
> > https://git.centos.org/summary/rpms!rh-java-common-easymock3
> 
> What is this? Is it the SCL?

No idea what SCL should mean. rh-java-common-easymock3 is an additional package in CentOS that's not available in RHEL.

> Note that easymock3 already exists and I have the EPEL7 commit and ACLs:
> 
> https://admin.fedoraproject.org/pkgdb/package/rpms/easymock3/
> 
> What are you recommending?

There are no commits (and no builds) so far in the epel7 branch. Rawhide is orphaned in favor of the major bump to version 3.x of the original easymock package.
Comment 10 Fedora Update System 2017-05-22 10:06:40 EDT
easymock3-3.3-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-3e9fddd828
Comment 11 Benjamin Lefoul 2017-05-22 10:08:31 EDT
Now, easymock3 is back to EPEL7.
Comment 12 Benjamin Lefoul 2017-05-22 10:13:28 EDT
BR override is up until the end of the month: https://bodhi.fedoraproject.org/overrides/easymock3-3.3-2.el7

Replace:
BuildRequires:  mvn(org.easymock:easymock)

With:
BuildRequires:  mvn(org.easymock:easymock) = 3.3
Comment 13 Benjamin Lefoul 2017-05-22 10:17:50 EDT
Actually replacing the BR is not even necessary, the "no package found" for easymock goes readily:

https://koji.fedoraproject.org/koji/taskinfo?taskID=19690454

DEBUG util.py:439:  Getting requirements for powermock-1.6.5-5.el7.src
DEBUG util.py:439:   --> maven-local-3.4.1-11.el7.noarch
DEBUG util.py:439:   --> apache-commons-logging-1.1.2-7.el7.noarch
DEBUG util.py:439:   --> tomcat-servlet-3.0-api-7.0.69-11.el7_3.noarch
DEBUG util.py:439:   --> junit-4.11-8.el7.noarch
DEBUG util.py:439:   --> maven-plugin-bundle-2.3.7-12.el7.noarch
DEBUG util.py:439:   --> assertj-core-2.2.0-2.el7.noarch
DEBUG util.py:439:   --> easymock3-3.3-2.el7.noarch
DEBUG util.py:439:   --> hamcrest-1.3-6.el7.noarch
DEBUG util.py:439:   --> javassist-3.16.1-10.el7.noarch
DEBUG util.py:439:   --> mockito-1.10.19-1.el7.noarch
DEBUG util.py:439:   --> objenesis-1.2-18.el7.noarch
DEBUG util.py:439:   --> sonatype-oss-parent-7-6.el7.noarch
DEBUG util.py:439:   --> testng-6.8.7-3.el7.noarch
DEBUG util.py:439:  Error: No Package found for mvn(cglib:cglib-nodep)

Now cglib should be fixed.
Comment 14 Fedora Update System 2017-05-22 14:07:02 EDT
easymock3-3.3-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-7fdc2a2584
Comment 15 Fedora Update System 2017-05-22 23:55:16 EDT
easymock3-3.3-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-3e9fddd828
Comment 16 Benjamin Lefoul 2017-05-23 01:56:57 EDT
easymock3-3.3-2.el7 is unpushed, easymock3-3.3-3.el7 is up.
Comment 17 Fedora Update System 2017-05-24 03:26:02 EDT
easymock3-3.3-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-7fdc2a2584
Comment 18 Fedora Update System 2017-06-08 04:27:23 EDT
easymock3-3.3-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.