Bug 129424 - Kudzu sets non-working IMPS/2 instead of working PS/2 at a HP Omnibook 6100 touchpad
Kudzu sets non-working IMPS/2 instead of working PS/2 at a HP Omnibook 6100 t...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-08 17:14 EDT by Robert Scheck
Modified: 2014-03-16 22:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 12:45:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-08-08 17:14:23 EDT
Description of problem:
Kudzu of Fedora Core 1 sets IMPS/2 for (X)MOUSETYPE in 
/etc/sysconfig/mouse but the touchpad isn't working fine using init 3 
and gpm. So the cursor hops and buckels strange and marks text I 
didn't want to mark and pastes also at using the touchpad - a typical 
IMPS/2 problem. 

Version-Release number of selected component (if applicable):
kudzu-1.1.36-1
kudzu-1.1.36.1-1

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. Have a HP Omnibook 6100 
2. Install Fedora Core 1 (textbased/minimal installation)
3. Boot it
4. Get the touchpad problem :(

Another way to Reproduce:
# enable kudzu for bootup
rm -f /etc/sysconfig/mouse
rm -f /etc/sysconfig/hwconf
reboot
  
Actual results:
Diff from non-working to working configuration file:

--- snipp ---
--- /etc/sysconfig/mouse         2004-08-08 23:00:47.000000000 +0200
+++ /etc/sysconfig/mouse.works   2004-08-08 22:34:11.000000000 +0200
@@ -1,5 +1,5 @@
 FULLNAME="Generic - 2 Button Mouse (PS/2)"
-MOUSETYPE="imps2"
+MOUSETYPE="ps2"
 XEMU3="yes"
-XMOUSETYPE="IMPS/2"
+XMOUSETYPE="PS2"
 DEVICE=/dev/psaux
--- snapp ---

Expected results:
Fine working touchpad, having automatically the default 
MOUSETYPE="ps2" and XMOUSETYPE="PS2" in /etc/sysconfig/mouse like 
above.

Additional info:
Relevant part from /etc/sysconfig/hwconf:

--- snipp ---
-
class: MOUSE
bus: PSAUX
detached: 0
device: psaux
driver: genericps/2
desc: "Generic Mouse (PS/2)"
-
--- snapp ---

FYI: This bug also affects Red Hat Enterprise Linux 3's latest 
kudzu-1.1.22.2-1.
Comment 1 Bill Nottingham 2004-08-10 12:23:06 EDT
Generic Mouse (PS/2) shouldn't be getting set to IMPS2 by
system-config-mouse ever.
Comment 2 Robert Scheck 2004-10-01 12:45:24 EDT
I'll close this bug report with "wontfix", because the live time of 
Fedora Core 1 is over. I think this issue isn't relevant to Fedora 
Core 2 and 3. Maybe the original issue is solved by the Fedora Legacy 
team.

Note You need to log in before you can comment on or make changes to this bug.