Bug 129425 - kernel-2.6.7-1.494.2.2 and kernel-2.6.8-1.521 fails to bring up ppp0
kernel-2.6.7-1.494.2.2 and kernel-2.6.8-1.521 fails to bring up ppp0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-08 17:27 EDT by Jarkko
Modified: 2015-01-04 17:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-22 02:25:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarkko 2004-08-08 17:27:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Just updated kernel-2.6.7-1.494.2.2 to kernel-2.6.7-1.494.2.2. Now ppp
is not working:

Aug  9 00:04:17 localhost ifup: /sbin/adsl-start: line 215:  2143
Terminated              $CONNECT "$@" >/dev/null 2>&1 
Aug  9 00:04:17 localhost network: Bringing up interface ppp0:  failed 

Version-Release number of selected component (if applicable):
kernel-2.6.7-1.494.2.2

How reproducible:
Always

Steps to Reproduce:
1. you need ppp (of course)
2. update to kernel-2.6.7-1.494.2.2
3. boot and try to activate ppp0
    

Actual Results:  It takes ages to try to bring up ppp0. It is not
activating.

Expected Results:  ppp0 should have been activated.

Additional info:

This is a very important bug because network is unreachable without a
working xDSL.
Comment 1 Jarkko 2004-08-08 17:31:27 EDT
Correction: "Just updated kernel-2.6.7-1.494.2.2 to
kernel-2.6.7-1.494.2.2" should read "Just updated
kernel-2.6.6-1.435.2.3 to kernel-2.6.7-1.494.2.2".
Comment 2 Jarkko 2004-08-20 12:11:59 EDT
The same thing happens with the newer kernel-2.6.8-1.521! What's going
on? Any clues? Something must have been changed between 2.6.6 and
2.6.7 in the kernel.
Comment 3 Jarkko 2004-08-23 15:50:00 EDT
http://fedoranews.org/updates/FEDORA-2004-267.shtml is talking about
some changes in the kernel networking code. That must be the cause of
this. If you think this should be fixed in pppd, please reassign this bug.

It's not very nice that I have to use the old kernel version (2.6.6)
for getting networking to work...
Comment 4 Jarkko 2004-09-09 02:17:45 EDT
I read from some other bug that updating rp-pppoe to the testing
version might help. So I installed rp-pppoe-3.5-15 and tried to boot
the computer. It did not help at all.

So, I don't still have a clue why isn't xDSL working with the kernels
newer than 2.6.6.
Comment 5 Jarkko 2004-10-15 16:47:41 EDT
Is this a hardware issue? Maybe you have left out support for my
ethernet adapter...

eth0 (which is used by ppp0) is:

79c978 [HomePNA]
Comment 6 Jarkko 2004-11-01 16:55:36 EST
Okay, this is pcnet32 kernel module issue. Debian has the same bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=271882
Comment 7 Jarkko 2004-11-01 17:18:06 EST
Finally found the cause! I'm running 2.6.8 at the moment. :)

If you have pcnet32 module and you're running HomePNA, you need to
specify homepna mode in /etc/modprobe.conf from 2.6.7 and up:

--
# use HomePNA mode with pcnet32
options pcnet32 homepna=1
--

This should be added automatically by system-config-network so that
user does not have to specify it by hand.
Comment 8 Jarkko 2004-11-22 02:25:33 EST
Closing. Not really a kernel bug although kernel update changes 
things.

Note You need to log in before you can comment on or make changes to this bug.