Bug 1294251 - update 1.5
update 1.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iksemel (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-25 15:33 EST by mastaiza
Modified: 2016-09-07 15:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: iksemel-1.5-0.1.git978b733.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-07 15:32:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mastaiza 2015-12-25 15:33:46 EST
Latest upstream release: 1.5
https://github.com/meduketto/iksemel
Comment 1 Jan Kurik 2016-02-24 09:10:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Orion Poplawski 2016-08-26 12:40:08 EDT
I've got a version of this, but it fails to build with current gnutls:

../src/.libs/libiksemel.so: undefined reference to `gnutls_mac_set_priority'
../src/.libs/libiksemel.so: undefined reference to `gnutls_protocol_set_priority'
../src/.libs/libiksemel.so: undefined reference to `gnutls_kx_set_priority'
../src/.libs/libiksemel.so: undefined reference to `gnutls_cipher_set_priority'
../src/.libs/libiksemel.so: undefined reference to `gnutls_compression_set_priority'

Looks like these have been replaced with http://www.gnutls.org/manual/gnutls.html#gnutls_005fpriority_005fset_005fdirect which may not be too hard to update.

1.5 also adds the ability to use openssl instead, and that builds.  But I don't know if that would be too much of a change.  zabbix is about the only user of iksemel other than asterisk, and it uses openssl, so I think the switch would be appreciated there.

Jeff - are you still around?
Comment 3 Orion Poplawski 2016-09-07 15:32:56 EDT
Updated and switched to openssl.

Note You need to log in before you can comment on or make changes to this bug.