This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1294263 - Qualcomm Atheros QCA6174 not working
Qualcomm Atheros QCA6174 not working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: linux-firmware (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-25 19:16 EST by hawking
Modified: 2016-05-22 08:12 EDT (History)
11 users (show)

See Also:
Fixed In Version: linux-firmware-20160505-64.git8afadbe5.fc24 linux-firmware-20160505-64.git8afadbe5.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-17 11:11:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hawking 2015-12-25 19:16:50 EST
In an Acer R5-471T-71W2, this nic does not work: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32). I saw a mention that including /etc/modprobe.d/ath10k.conf with "options ath10k_core skip_otp=y" might help, but the visibility of the card disappears entirely with that present on boot.

When using another usb-nic (and no ath10k.conf), it does show up as listed, with "device not ready" listed, but the entire system seems to lag. Not using ath10k.conf (and thus with the Atheros card showing up) causes the external usb-nic to also crash.

Kernel
Version     : 4.2.8
Release     : 300.fc23


lspci -v

    01:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
            Subsystem: Foxconn International, Inc. Device e09d
            Flags: bus master, fast devsel, latency 0, IRQ 125
            Memory at a1000000 (64-bit, non-prefetchable) [size=2M]
            Capabilities: <access denied>
            Kernel driver in use: ath10k_pci
            Kernel modules: ath10k_pci


lspci -nn

    01:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)


dmesg | grep ath10k

    [   14.321291] ath10k_pci 0000:01:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
    [   14.480823] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/cal-pci-0000:01:00.0.bin failed with error -2
    [   14.481732] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/board-pci-168c:003e:105b:e09d.bin failed with error -2
    [   14.481735] ath10k_pci 0000:01:00.0: failed to load spec board file, falling back to generic: -2
    [   14.482301] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
    [   14.482304] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
    [   16.616042] ath10k_pci 0000:01:00.0: qca6174 hw3.2 (0x05030000, 0x00340aff, 168c:003e:105b:e09d fallback) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 api 4 htt 3.26 wmi 4 cal otp max_sta 32
    [   16.616045] ath10k_pci 0000:01:00.0: debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
    [   18.777065] ath10k_pci 0000:01:00.0 wlp1s0: renamed from wlan0
    [   24.006346] ath10k_pci 0000:01:00.0: failed to enable dynamic BW: -11
    [   27.005853] ath10k_pci 0000:01:00.0: could not suspend target (-11)
    [   35.262376] ath10k_pci 0000:01:00.0: failed to enable dynamic BW: -11
    [   38.261964] ath10k_pci 0000:01:00.0: could not suspend target (-11)
Comment 1 hawking 2015-12-26 10:49:45 EST
Confirmed essentially the same situation and error messages on today's rawhide, kernel 4.4
Comment 2 hawking 2015-12-31 18:56:12 EST
Upstream discussion resulted in a potential solution: 
https://bugzilla.kernel.org/show_bug.cgi?id=108791

Replacing the board.bin with the windows bin linked in comment 2 (https://bugzilla.kernel.org/attachment.cgi?id=196391) in /lib/firmware/ath10k/QCA6174/hw3.0/ seems to make the wireless work with kernel 4.2.8 / F23.
Comment 3 Josh Boyer 2016-01-04 08:49:37 EST
Unfortunately, we cannot ship the firmware file linked in the upstream bug.  We'll have to wait for the upstream linux-firmware files to be updated.
Comment 4 Dagan McGregor 2016-01-08 13:00:10 EST
CC'ing myself to this bug to track firmware updates.

Currently using F23, kernel 4.2.8-30 on Acer Aspire VN7-792G

The device appears as an available device, but is unable to find any wireless network to connect to.

Previous kernels did not show the device at all.
Comment 5 Dagan McGregor 2016-02-09 07:39:29 EST
Is there any work on this upstream?

I don't see any change in the latest firmware package.
Comment 6 Denis Marchand 2016-04-11 07:45:40 EDT
Bug persits with Fedora 24 alpha...
Comment 7 James Hogarth 2016-04-14 18:04:45 EDT
As a heads up looks like the firmware arrived upstream 26th Feb:

https://github.com/kvalo/ath10k-firmware/commits/master/QCA6174

It has not been merged into the linux-firmware tree quite yet though.

Shouldn't be much longer to wait for this to work out the box in Fedora.
Comment 8 Dagan McGregor 2016-04-14 18:21:58 EDT
I believe that update from February is what I am currently using. 

It "works for me" on my home wireless. Cisco E4200 w/ DD-WRT, WPA2 Personal & AES, set to use 802.11n. I don't have a 802.11ac AP to test with.

However the connection speeds reported in Gnome/Network manager show quite low - 1Mbit-6Mbit - while the status page on the DD-WRT status page show connection speeds 50Mbit+.

It's an improvement over not having anything at all.
Comment 9 James Hogarth 2016-04-28 06:52:48 EDT
David is it possible to include the commits from kvalo's upstream or do you need to wait for his pull request to the kernel linux-firmware tree?
Comment 10 Josh Boyer 2016-04-28 07:04:00 EDT
(In reply to James Hogarth from comment #9)
> David is it possible to include the commits from kvalo's upstream or do you
> need to wait for his pull request to the kernel linux-firmware tree?

We wait for it to be in the linux-firmware tree.
Comment 11 James Hogarth 2016-04-28 07:05:12 EDT
thanks for the info Josh

I'll be patient with the RPM and keep copying manually for now ;)
Comment 12 James Hogarth 2016-05-05 06:09:15 EDT
For those following this issue as a heads up the pull request has landed in the kernel.org linux-firmware repository.
Comment 13 Josh Boyer 2016-05-05 09:48:11 EDT
I've updated the linux-firmware package on the f23 - rawhide branches and started builds.
Comment 14 Fedora Update System 2016-05-16 08:34:21 EDT
linux-firmware-20160505-64.git8afadbe5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b8f5d5b375
Comment 15 Fedora Update System 2016-05-16 08:35:07 EDT
linux-firmware-20160505-64.git8afadbe5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3da5490f91
Comment 16 Fedora Update System 2016-05-16 19:55:47 EDT
linux-firmware-20160505-64.git8afadbe5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3da5490f91
Comment 17 Fedora Update System 2016-05-17 00:24:18 EDT
linux-firmware-20160505-64.git8afadbe5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b8f5d5b375
Comment 18 Fedora Update System 2016-05-17 11:11:12 EDT
linux-firmware-20160505-64.git8afadbe5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2016-05-17 22:52:17 EDT
linux-firmware-20160505-64.git8afadbe5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Denis Marchand 2016-05-22 08:12:23 EDT
Problem fixed for me with the latest update for Fedora 23. And I can connect to 802.11ac networks ! 

Thanks everyone !

Denis

Note You need to log in before you can comment on or make changes to this bug.