Bug 1294284 - configuration UI sometimes missing a few important details
configuration UI sometimes missing a few important details
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager-strongswan (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Šimerda (pavlix)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-26 07:48 EST by Thorsten Leemhuis
Modified: 2016-10-26 23:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: NetworkManager-strongswan-1.3.1-1.fc23.1 NetworkManager-strongswan-1.4.0-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-05 04:50:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2015-12-26 07:48:15 EST
Description of problem:
The configuration UI offered by NetworkManager-strongswan-gnome misses fields to change keys or other details. I'm seeing it on F23 and it was also mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=863836#c32 earier.
I had a package witch fixed this the same way openSUSE did it in 
https://bugzilla.suse.com/show_bug.cgi?id=944769
That bug has more details and liks to bugs in Ubuntu and Debian. The patches in question can be found here:
https://build.opensuse.org/package/view_file/openSUSE:Leap:42.1/NetworkManager-strongswan/nm-strongswan-fix-config.patch?expand=1
https://build.opensuse.org/package/view_file/openSUSE:Leap:42.1/NetworkManager-strongswan/nm-strongswan-UI-fixup.patch?expand=1

They seem to be needed to make the current F23 version work properly. I wanted to send you a patch for the version in Fedora git, but that currently doesn't compile anymore (" main.c:43:2: error: 'gnome_keyring_find_network_password_sync' is deprecated: Use 'SECRET_SCHEMA_COMPAT_NETWORK' instead [-Werror=deprecated-declarations] ") and there was no straight-forward way to fix. Maybe you could take a look? 

Note that the bug is not that important to me, it works for me as long as I don't have to change my configuration ;-) But it might be a problem for others; and the root of the problem might still be there in the rawhide branch, too.
Comment 1 Jan Doumont 2016-01-22 20:38:02 EST
I also suffered from this bug. 'manually' installing the package from openSUSE resolved this for me.

Should be fixed at some point, because the whole idea for this package is providing the UI, and essential fields were missing.
Comment 2 Jan Doumont 2016-01-23 21:39:01 EST
For those in need of a workaround:

Launch 'nm-connection-editor', and add the VPN from there.
Comment 3 Fedora Update System 2016-09-23 02:52:48 EDT
NetworkManager-strongswan-1.3.1-1.fc23.1 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-43494300d1
Comment 4 Fedora Update System 2016-09-23 04:00:53 EDT
NetworkManager-strongswan-1.4.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3600786766
Comment 5 Fedora Admin XMLRPC Client 2016-09-27 09:39:13 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Update System 2016-09-28 01:58:36 EDT
NetworkManager-strongswan-1.4.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3600786766
Comment 7 Fedora Update System 2016-10-05 04:50:44 EDT
NetworkManager-strongswan-1.3.1-1.fc23.1 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-10-26 23:21:21 EDT
NetworkManager-strongswan-1.4.0-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.