Bug 1294289 - Cura slowly fills your harddrive up with log file
Cura slowly fills your harddrive up with log file
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: cura (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-26 09:12 EST by John Duchek
Modified: 2016-12-20 12:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 12:23:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Duchek 2015-12-26 09:12:44 EST
Description of problem:
Cura slowly builds up the .xsessions-errors.old with something like
'[_]'  characters (brackets are right, could be a different character in the middle (I am not on the affected computer).  Over a week of 3D printing I filled up a 60GB harddrive.  

Version-Release number of selected component (if applicable):
15.02

How reproducible:
I have now filled 2 hard drives before I located the problem in the .xsession-errors.old file and deleted it. 

Steps to Reproduce:
1. run cura to control 3D printing operations
2.With each run that file gets larger.
3.Hard drive starts reporting it is full and that cura can no longer write log files.

Actual results:
hard drive becomes unusable.

Expected results:
.xsession-errors.old needs to have stable size.

Additional info:
Problem can be relieved by deleting .xsession-errors.old.
Comment 1 Miro Hrončok 2015-12-29 16:03:35 EST
Do you need to print or just run cura?
Comment 2 John Duchek 2016-01-01 08:57:03 EST
It seems to add to the .xsessions-errors.old file each time it prints.  In addition I am beginning to see an instability in the program.  Since the last kernel upgrade (~a week or so ago), it seems to screw up the print somewhere in the middle.  It will just stop printing, or will just start printing spagetti sometime during the print out.  It has done that on its last 5 print outs. 
I am not sure if it is related to the new kernel or not, but I had not seen that behavior before.

I am currently running memory checks on the computer to see if the hardware has a problem.  If I find one I will post.
Comment 3 John Duchek 2016-01-01 08:59:20 EST
I am looking at the latest .xsession-errors.old and am seeing that it is still doing it.  it is adding ['']  (exact repeat hundreds of times).
john
Comment 4 John Duchek 2016-01-01 21:03:50 EST
Here is a bit more information.
I printed a ruler with 9 lines and 9 numbers tonight.  (9 cm ruler to calibrate printe).  The lines were present in the finished product but the numbers were not so I don't think it completed the ruler.  

I ran cura from the command line.  The following was printed in the terminal
load preferences from /home/jduchek/.cura/15.02.1/preferences.ini
Listening for engine communications on 49674
['changeZ', '15']
['changeZ', '0']
['changeZ', '0']
['changeZ', '0']
['changeZ', '0']
['changeZ', '1']
['changeZ', '1']
['changeZ', '1']
['changeZ', '6']

The changeZ lines came out just before it stopped printing and moved the extruder to the corner.
Comment 5 Miro Hrončok 2016-01-07 06:56:42 EST
I'm quite unable to look into this for at least a week. In the meantime, you can try if cura-lulzbot works and if so, use that.
Comment 6 John Duchek 2016-01-07 09:09:25 EST
I will try that.  Thanks,  I will check and see if it is doing the same while I am at it.  Now that I know where the problem is I can always delete the log when it gets too big. 
John
Comment 7 John Duchek 2016-01-11 20:47:06 EST
I tried cura-lulzbot.  It sort of works.  However, it takes an stl that slic3r handles well, and gives a bunch of script errors. Things like 'last line has no checksum'.  Several times I have had it print an object and then crash when it tries to print the same file a second time.  
I am also finding cura crashing.  In both cases it executes maybe half the object and then stops and dumps plastic in the same spot for a while and never starts again.  
The system has frozen a couple times during cura and cura-lulzbot runs.  It is not freezing when the same file is printer by pronterface/slic3r.

The computer has not frozen at any time when one of the curas is running.  

I know that is not any specific help.  I will keep trying to add detail.
John
Comment 8 John Duchek 2016-01-11 20:48:05 EST
I misspoke

The computer has not frozen at any time other than when one of the curas is running. 

John
Comment 9 Fedora End Of Life 2016-11-24 09:31:30 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2016-12-20 12:23:41 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.