Bug 1294355 - German translation incomplete on delta RPMS
Summary: German translation incomplete on delta RPMS
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-27 14:42 UTC by Frank Büttner
Modified: 2016-02-22 21:06 UTC (History)
7 users (show)

Fixed In Version: dnf-1.1.7-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 21:06:46 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete screen shot (181.74 KB, image/png)
2015-12-27 14:42 UTC, Frank Büttner
no flags Details
f23 DNF whith same bug (100.27 KB, image/png)
2015-12-27 20:36 UTC, Matthias31
no flags Details

Description Frank Büttner 2015-12-27 14:42:38 UTC
Created attachment 1109820 [details]
Complete screen shot

Description of problem:
When the delta packages will be down loaded/build , the ready messages are not translated.

Version-Release number of selected component (if applicable):
dnf-langpacks-0.15.1-1.fc22.noarch

How reproducible:
Every time

Steps to Reproduce:
1. call dnf update


Actual results:
Pakete werden heruntergeladen:
8/8): perl-libwww-perl-6.13-1.fc22_6.15-1.fc22.noarch.drpm
[DRPM] perl-libwww-perl-6.13-1.fc22_6.15-1.fc22.noarch.drpm: done

Expected results:
Pakete werden heruntergeladen:
8/8): perl-libwww-perl-6.13-1.fc22_6.15-1.fc22.noarch.drpm
[DRPM] perl-libwww-perl-6.13-1.fc22_6.15-1.fc22.noarch.drpm: fertig

Comment 1 Matthias31 2015-12-27 20:36 UTC
Created attachment 1109883 [details]
f23 DNF whith same bug

in fedora 23 dnf has the same bug

Comment 2 Parag Nemade 2015-12-28 05:12:05 UTC
This is a dnf issue. That "Done" string need to be enabled for translation.

Comment 3 Honza Silhan 2016-01-04 12:59:25 UTC
thx, Parag.

Comment 4 Fedora Update System 2016-01-26 10:34:34 UTC
dnf-plugins-core-0.1.16-1.fc23 dnf-1.1.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-80cbf309b4

Comment 5 Fedora Update System 2016-01-26 10:35:49 UTC
dnf-plugins-core-0.1.16-1.fc22 dnf-1.1.6-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37

Comment 6 Fedora Update System 2016-01-26 19:52:51 UTC
dnf-1.1.6-1.fc23, dnf-plugins-core-0.1.16-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-80cbf309b4

Comment 7 Frank Büttner 2016-01-27 06:50:52 UTC
1.1.6-1 don't solve it. (same as before)
See the comment on bodhi for more.

Comment 8 Parag Nemade 2016-01-27 08:49:13 UTC
Frank, See the translation is missing https://github.com/rpm-software-management/dnf/blob/master/po/de.po#L62

Once its translated or if already on Zanata then pulled from Zanata to github dnf code, it will be available in next release of dnf.

Maybe move this back to Assigned till translations get merged upstream.

Comment 9 Fedora Update System 2016-01-28 18:20:11 UTC
dnf-1.1.6-1.fc23, dnf-plugins-core-0.1.16-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Frank Büttner 2016-01-28 18:44:18 UTC
Not solved

Comment 11 Fedora Update System 2016-01-28 23:19:28 UTC
dnf-1.1.6-1.fc22, dnf-plugins-core-0.1.16-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37

Comment 12 Arnaud 2016-02-02 23:41:42 UTC
Is it possible this change affected the French version, we get word repeated ? 
Install -> Installationationationation
GROUPE -> GROUPEEEE
no -> nonnnn
(etc., didn't look all)

It doesn't do it keeping:
dnf-langpacks-0.15.1-1.fc23.noarch

but downgrade dnf to:
dnf-1.1.5-1.fc23.noarch.rpm
dnf-conf-1.1.5-1.fc23.noarch.rpm
dnf-yum-1.1.5-1.fc23.noarch.rpm
python2-dnf-1.1.5-1.fc23.noarch.rpm
python3-dnf-1.1.5-1.fc23.noarch.rpm

Comment 13 Parag Nemade 2016-02-03 03:20:17 UTC
Heldwin, its translations issue. Please find who last did the translations on Zanata for dnf's fr.po file. I can clearly see this

msgid "GROUP"
msgstr "GROUPEEEE"

msgid "Group"
msgstr "Groupeeee"

msgid "no"
msgstr "nonnnn"

msgid "Install"
msgstr "Installationationationation"

Comment 14 Fedora Update System 2016-02-03 13:06:50 UTC
dnf-1.1.6-2.fc22 dnf-plugins-core-0.1.16-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37

Comment 15 Fedora Update System 2016-02-03 23:26:59 UTC
dnf-1.1.6-2.fc22, dnf-plugins-core-0.1.16-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37

Comment 16 Fedora Update System 2016-02-17 04:22:19 UTC
dnf-1.1.6-2.fc22, dnf-plugins-core-0.1.16-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Frank Büttner 2016-02-17 16:13:28 UTC
dnf-1.1.6-2.fc23.noarch and dnf-plugins-core-0.1.16-1.fc23.noarch have the bug to.
Gesamte Downloadgröße: 12 M
Ist dies in Ordnung? [j/N] : j
Pakete werden heruntergeladen:
(1/14): enca-1.16-1.fc23_1.18-1.fc23.x86_64.drpm                                                                     76 kB/s |  40 kB     00:00    
(2/14): gdm-3.18.2-1.fc23_3.18.2-2.fc23.x86_64.drpm                                                                 466 kB/s | 300 kB     00:00    
[DRPM] enca-1.16-1.fc23_1.18-1.fc23.x86_64.drpm: done                                                                                              
(3/14): glusterfs-3.7.6-2.fc23_3.7.8-1.fc23.x86_64.drpm                                                             379 kB/s | 123 kB     00:00    
(4/14): glusterfs-libs-3.7.6-2.fc23_3.7.8-1.fc23.x86_64.drpm                                                        220 kB/s |  64 kB     00:00    
(5/14): glusterfs-api-3.7.6-2.fc23_3.7.8-1.fc23.x86_64.drpm                                                         156 kB/s |  42 kB     00:00    
[DRPM] glusterfs-libs-3.7.6-2.fc23_3.7.8-1.fc23.x86_64.drpm: done                                                                                  
(6/14): coreutils-8.24-5.fc23_8.24-6.fc23.x86_64.drpm                                                               1.0 MB/s | 1.2 MB     00:01    
[DRPM] glusterfs-3.7.6-2.fc23_3.7.8-1.fc23.x86_64.drpm: done                                                                                       
[DRPM] glusterfs-api-3.7.6-2.fc23_3.7.8-1.fc23.x86_64.drpm: done                                                                                   
(7/14): glusterfs-client-xlators-3.7.6-2.fc23_3.7.8-1.fc23.x86_64.drpm

Comment 18 Honza Silhan 2016-02-22 21:06:46 UTC
"done" string when drpm is downloaded should contain German translation in [1]. french translations from comment 12 seems to be alright as well.

[1] https://github.com/rpm-software-management/dnf/commit/33a760ac2e5b5cd8f7606498814fba2283a02d79


Note You need to log in before you can comment on or make changes to this bug.