This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1294362 - [abrt] xpra: connection.py:584:call_async:ValueError: Unable to guess signature from an empty list
[abrt] xpra: connection.py:584:call_async:ValueError: Unable to guess signatu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xpra (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:18f3142b76422a7d3667d0ad1b3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-27 11:39 EST by Karel Volný
Modified: 2016-04-08 11:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: xpra-0.16.3-1.fc24 xpra-0.16.3-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-02 12:44:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.86 KB, text/plain)
2015-12-27 11:39 EST, Karel Volný
no flags Details
File: environ (3.48 KB, text/plain)
2015-12-27 11:39 EST, Karel Volný
no flags Details

  None (edit)
Description Karel Volný 2015-12-27 11:39:27 EST
Version-Release number of selected component:
xpra-0.15.10-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python /usr/bin/xpra --tray=yes --dpi=100 --encoding=png/P --keyboard-sync=no attach ssh:kavol@jarmilka.hajnet.cz:100
dso_list:       dbus-python-1.2.0-12.fc23.x86_64
executable:     /usr/bin/xpra
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
connection.py:584:call_async:ValueError: Unable to guess signature from an empty list

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 607, in msg_reply_handler
    *message.get_args_list()))
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 416, in _introspect_error_handler
    self._introspect_execute_queue()
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 387, in _introspect_execute_queue
    proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 137, in __call__
    **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 584, in call_async
    message.append(signature=signature, *args)
ValueError: Unable to guess signature from an empty list

Local variables in innermost frame:
bus_name: dbus.UTF8String(':1.1522')
byte_arrays: False
self: <dbus._dbus.SessionBus (session) at 0x7f93bd991110>
args: ('Xpra', 0, 'kmail', 'Upozorn\xc4\x9bn\xc3\xad na nov\xc3\xbd e-mail', 'Od: logwatch@kurva236.hajnet.cz\nP\xc5\x99edm\xc4\x9bt: Logwatch for kurva236.hajnet.cz (Linux)\nV: P\xc5\x99\xc3\xadchoz\xc3\xad', [], [], -1)
require_main_loop: True
object_path: '/org/freedesktop/Notifications'
signature: None
reply_handler: <bound method DBUS_Notifier.cbReply of <xpra.client.notifications.dbus_notifier.DBUS_Notifier object at 0x7f93bd9a5990>>
error_handler: <bound method DBUS_Notifier.cbError of <xpra.client.notifications.dbus_notifier.DBUS_Notifier object at 0x7f93bd9a5990>>
dbus_interface: 'org.freedesktop.Notifications'
timeout: -1.0
kwargs: {}
e: ValueError('Unable to guess signature from an empty list',)
message: <dbus.lowlevel.MethodCallMessage path: /org/freedesktop/Notifications, iface: org.freedesktop.Notifications, member: Notify dest: :1.1522>
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
method: 'Notify'
Comment 1 Karel Volný 2015-12-27 11:39:32 EST
Created attachment 1109835 [details]
File: backtrace
Comment 2 Karel Volný 2015-12-27 11:39:33 EST
Created attachment 1109836 [details]
File: environ
Comment 3 Jonathan Underwood 2015-12-27 17:16:33 EST
Haven't managed to reproduce this. Any idea what you were doing when it happened?
Comment 4 Karel Volný 2015-12-29 12:02:14 EST
(In reply to Jonathan Underwood from comment #3)
> Any idea what you were doing when it happened?

unfortunately not, I've found it while processing some older crashes (abrt sometimes doesn't show things immediately :-( )

but if the problem is with the notification ... sometimes, plasmashell freezes while displaying notifications, could that be that it puts dbus in some wrong state which then leads to a problem in xpra?
Comment 5 Jonathan Underwood 2015-12-29 12:32:26 EST
(In reply to Karel Volný from comment #4)
> (In reply to Jonathan Underwood from comment #3)
> > Any idea what you were doing when it happened?
> 
> unfortunately not, I've found it while processing some older crashes (abrt
> sometimes doesn't show things immediately :-( )
> 
> but if the problem is with the notification ... sometimes, plasmashell
> freezes while displaying notifications, could that be that it puts dbus in
> some wrong state which then leads to a problem in xpra?

Hm, could be. I know upstream has had a lot of problems keeping up with notifications across the different desktop environments it targets, and kde/plasma/system tray (absence) support is probably in the worst shape. I'll leave this open in the hope we can find a reliable reproducer to take upstream.
Comment 6 Jonathan Underwood 2015-12-29 12:33:09 EST
Just so we have a clear picture - what's your dekstop environment exactly?
Comment 7 Karel Volný 2015-12-31 06:04:23 EST
(In reply to Jonathan Underwood from comment #6)
> Just so we have a clear picture - what's your dekstop environment exactly?

KDE

by the time of the crash, I believe the relevant package version was:
plasma-workspace-5.5.0-4.fc23.x86_64

(is this the one including the notifications handler, right?)
Comment 8 Fedora Update System 2016-03-24 11:24:48 EDT
xpra-0.16.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b8890ebde4
Comment 9 Fedora Update System 2016-03-24 11:31:20 EDT
xpra-0.16.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-28d5c6ddaa
Comment 10 Fedora Update System 2016-03-24 11:31:41 EDT
xpra-0.16.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b8890ebde4
Comment 11 Fedora Update System 2016-03-25 16:28:05 EDT
xpra-0.16.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-28d5c6ddaa
Comment 12 Fedora Update System 2016-03-26 11:20:06 EDT
xpra-0.16.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b8890ebde4
Comment 13 Fedora Update System 2016-04-02 12:44:08 EDT
xpra-0.16.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-04-08 11:55:13 EDT
xpra-0.16.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.