Bug 1294363 - nethogs fails with "creating socket failed while establishing local IP - are you root?"
Summary: nethogs fails with "creating socket failed while establishing local IP - are ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nethogs
Version: 23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anderson Silva
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-27 18:02 UTC by srakitnican
Modified: 2016-02-17 01:57 UTC (History)
1 user (show)

Fixed In Version: nethogs-0.8.2-1.20160101snap.fc23 nethogs-0.8.2-1.20160101snap.el7 nethogs-0.8.2-2.20160101snap.fc22 nethogs-0.8.2-2.20160101snap.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-03 21:51:42 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1294322 0 unspecified CLOSED nethog fails to establish socket as in debian bug #808433 2021-02-22 00:41:40 UTC

Internal Links: 1294322

Description srakitnican 2015-12-27 18:02:02 UTC
Description of problem:

$ sudo nethogs enp4s0
creating socket failed while establishing local IP - are you root?

Version-Release number of selected component (if applicable):
kernel-4.2.8-300.fc23.x86_64
nethogs-0.8.0-10.fc23.x86_64

How reproducible: Always


Steps to Reproduce:
1.
2.
3.

Actual results: nethogs doesn't start


Expected results:


Additional info: Possible related issue and fix: https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1380676.html

Seems like it's fixed in nethogs version 0.8.1

Comment 1 Anderson Silva 2016-01-01 17:39:19 UTC
Thanks for the heads up. I just contacted upstream because I didn't even know 0.8.1 was out since their main web site hasn't been updated in years.

It seems 0.8.2 maybe coming out very soon as per: https://github.com/raboof/nethogs

So, I may just package that up...

Comment 2 Anderson Silva 2016-01-01 17:40:54 UTC
never mind on 0.8.2, I will package up 0.8.1

Comment 3 Fedora Update System 2016-01-01 19:02:06 UTC
nethogs-0.8.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a18ee78ca9

Comment 4 Fedora Update System 2016-01-01 20:18:34 UTC
nethogs-0.8.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-008e3ee033

Comment 5 Fedora Update System 2016-01-02 00:29:40 UTC
nethogs-0.8.2-1.20160101snap.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8c0609023e

Comment 6 Fedora Update System 2016-01-02 00:37:03 UTC
nethogs-0.8.2-1.20160101snap.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-95ea41d759

Comment 7 Fedora Update System 2016-01-03 02:51:18 UTC
nethogs-0.8.2-1.20160101snap.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-95ea41d759

Comment 8 Fedora Update System 2016-01-03 03:23:15 UTC
nethogs-0.8.2-1.20160101snap.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8c0609023e

Comment 9 Clodoaldo Pinto Neto 2016-01-11 16:09:54 UTC
Why not Fedora 22?

Comment 10 Anderson Silva 2016-01-11 18:03:36 UTC
(In reply to Clodoaldo Pinto Neto from comment #9)
> Why not Fedora 22?

Is it broken in Fedora 22? I don't have any F22 install to test it on. If it is, I can build for it.

Comment 11 Clodoaldo Pinto Neto 2016-01-11 18:07:31 UTC
Yes it is broken in 22. 0.8.2 works when built from source.

Comment 12 Fedora Update System 2016-01-11 20:23:09 UTC
nethogs-0.8.2-1.20160101snap.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-687fddd5ea

Comment 13 Fedora Update System 2016-01-12 08:01:43 UTC
nethogs-0.8.2-1.20160101snap.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-01-12 09:54:08 UTC
nethogs-0.8.2-1.20160101snap.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-687fddd5ea

Comment 15 Clodoaldo Pinto Neto 2016-01-12 12:20:11 UTC
The new 0.8.2 Fedora 22 package works for me.

Comment 16 Fedora Update System 2016-01-22 19:01:51 UTC
nethogs-0.8.2-2.20160101snap.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9f9e3a8229

Comment 17 Fedora Update System 2016-01-22 19:07:58 UTC
nethogs-0.8.2-2.20160101snap.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-75915b8111

Comment 18 Fedora Update System 2016-01-24 01:06:01 UTC
nethogs-0.8.2-1.20160101snap.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2016-01-24 04:22:37 UTC
nethogs-0.8.2-2.20160101snap.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-75915b8111

Comment 20 Fedora Update System 2016-01-24 04:50:38 UTC
nethogs-0.8.2-2.20160101snap.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9f9e3a8229

Comment 21 Fedora Update System 2016-02-03 21:51:37 UTC
nethogs-0.8.2-2.20160101snap.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2016-02-17 01:57:36 UTC
nethogs-0.8.2-2.20160101snap.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.