Bug 1294369 - gtkd has several incorrect Requires [NEEDINFO]
gtkd has several incorrect Requires
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtkd (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: MERCIER Jonathan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-27 13:55 EST by Yaakov Selkowitz
Modified: 2016-07-27 14:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: gtkd-3.2.2-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 14:54:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
yselkowi: needinfo? (bioinfornatics)


Attachments (Terms of Use)

  None (edit)
Description Yaakov Selkowitz 2015-12-27 13:55:25 EST
There are several issues in gtkd's Requires since commit 463e215 (F22):

* libglade is a GNOME 1.x (!) library which also pulls in the obsolete libxml (not to be confused with libxml2).  (In the gtk2 versions of gtkd, this was correctly listed as libglade2.)  This dependency should be dropped, as there is no libglade for GTK 3.x.

* gtkglext (incorrectly pulled in with -devel) is a gtk2 library.  gtkd wraps a gtk3 version, but that exists solely as an unreleased fork at <https://github.com/tdz/gtkglext>.  Therefore, this too should be dropped unless and until a gtkglext3 package is made.

* The current versions of gtkd wrap gstreamer1{,-plugins-base}, not the deprecated 0.10 ('gstreamer') versions.

* The vte3 library path is unversioned, therefore vte3-devel is required.  Note that this has been changed to vte291-devel in upstream master (post-3.2.1).
Comment 1 MERCIER Jonathan 2016-01-05 04:33:31 EST
Thanks for your report I will update it soon
Comment 2 MERCIER Jonathan 2016-01-05 05:42:52 EST
After a check https://github.com/tdz/gtkglext seems really a dead project. 
Any update since 4 years ... arf
Comment 3 Jan Kurik 2016-02-24 09:10:56 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 stan 2016-03-11 12:13:34 EST
Seeing a couple of errors related to gtkd in rawhide (f25).

Error: nothing provides vt291 needed by gtkd-3.2.2-1.fc24.x86_64.
package gtkd-geany-tags-3.2.2-1.fc24.noarch requires gtkd = 3.2.2-1.fc24, but none of the providers can be installed.

Found them using  dnf update --best
Comment 5 Yaakov Selkowitz 2016-03-11 12:20:32 EST
(In reply to stan from comment #4)
> Seeing a couple of errors related to gtkd in rawhide (f25).
> 
> Error: nothing provides vt291 needed by gtkd-3.2.2-1.fc24.x86_64.
> package gtkd-geany-tags-3.2.2-1.fc24.noarch requires gtkd = 3.2.2-1.fc24,
> but none of the providers can be installed.

That's a typo in the spec, it should be vte291.

Also, the glade3-libgladeui dependency is bogus.  It should be removed.
Comment 6 Fedora Update System 2016-07-19 02:40:03 EDT
gtkd-3.2.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e8eba6aeee
Comment 7 Fedora Update System 2016-07-19 21:54:17 EDT
gtkd-3.2.2-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e8eba6aeee
Comment 8 Fedora Update System 2016-07-27 14:54:14 EDT
gtkd-3.2.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.