Bug 1294374 - Containers: unable to display containers timeline
Containers: unable to display containers timeline
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Daniel Korn
Dafna Ron
container
:
Depends On:
Blocks: 1300376 1287858 1289199 1295430
  Show dependency treegraph
 
Reported: 2015-12-27 15:12 EST by Avi Tal
Modified: 2016-06-29 11:24 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1295430 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:24:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (821.76 KB, image/png)
2015-12-27 15:12 EST, Avi Tal
no flags Details
logs (1.23 MB, application/x-gzip)
2015-12-27 15:20 EST, Avi Tal
no flags Details

  None (edit)
Description Avi Tal 2015-12-27 15:12:00 EST
Description of problem:
Endless loop while opening Containers Timeline

Version-Release number of selected component (if applicable):
5.5.2.0 early buid

How reproducible:
always

Steps to Reproduce:
1. Containers -> Containers
2. <choose container> -> monitoring -> Timeline
3.

Actual results:
The circle will keep running, like it waiting to open, but the page will never load.

Expected results:
Open containers Timelines web page

Additional info:
attached screenshot
Comment 2 Avi Tal 2015-12-27 15:12 EST
Created attachment 1109867 [details]
screenshot
Comment 3 Avi Tal 2015-12-27 15:16:05 EST
Strange but the logs doesn't show any relevant ERROR or warning (evm.log, production.log, api.log)
Comment 4 Avi Tal 2015-12-27 15:20 EST
Created attachment 1109869 [details]
logs
Comment 5 Federico Simoncelli 2015-12-29 10:34:55 EST
Avi can you check if the same issue happens with VMs? (Trying to access a VM timeline).
Comment 6 Avi Tal 2015-12-30 04:25:19 EST
(In reply to Federico Simoncelli from comment #5)
> Avi can you check if the same issue happens with VMs? (Trying to access a VM
> timeline).

So i have attached the OpenStack infra that holds my container nodes.
Couldn't reproduce Timelines issue on instances timeline.
Comment 10 Daniel Korn 2016-01-05 07:33:45 EST
proposed fix: https://github.com/ManageIQ/manageiq/pull/6035

The problem was introduced as part of a refactor in container controller (PR #5738) in which two variables were not set in the explorer while needed for the rendered layout.
app/views/layouts/application.html.haml does not rendered again when replacing part of the page (replace_right_cell method).
Comment 13 errata-xmlrpc 2016-06-29 11:24:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.