Bug 1294422 - nova driver failed to attach volume because keymgr.fixed_key not defined by the installer [NEEDINFO]
nova driver failed to attach volume because keymgr.fixed_key not defined by ...
Status: CLOSED DUPLICATE of bug 1478161
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity urgent
: ---
: 12.0 (Pike)
Assigned To: Sven Anderson
Prasanth Anbalagan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 02:45 EST by bkopilov
Modified: 2017-09-27 07:20 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-27 07:20:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
svanders: needinfo? (bkopilov)


Attachments (Terms of Use)
nova logs (compute) (23.40 KB, application/x-gzip)
2015-12-28 03:01 EST, bkopilov
no flags Details

  None (edit)
Description bkopilov 2015-12-28 02:45:57 EST
Description of problem:
rhel7.2 , rhos 8 
installed with openstack director.

Looks like nova.conf (compute) is not configured with fixed key manager

From nova logs:
1eb705bf, exception: Requested operation is not valid: cpu affinity is not supported
2015-12-27 05:19:14.313 15447 WARNING nova.virt.libvirt.driver [req-d03d9636-dd05-463d-bcea-a6e719545966 b68123435e544ca2ab7edb337b4b22e0 098a8690f3fe4a059d88b06415ece74c - - -] [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf] Timeout waiting for vif plugging callback for instance ce421ad3-132c-4b79-91bd-df1c1eb705bf
2015-12-27 05:19:25.006 15447 WARNING nova.virt.libvirt.driver [req-0f3bcbfd-ae0c-4636-9b15-ba624abda9cf b68123435e544ca2ab7edb337b4b22e0 098a8690f3fe4a059d88b06415ece74c - - -] [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf] Ignoring supplied device name: /dev/vdb
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [req-0f3bcbfd-ae0c-4636-9b15-ba624abda9cf b68123435e544ca2ab7edb337b4b22e0 098a8690f3fe4a059d88b06415ece74c - - -] [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf] Failed to attach volume at mountpoint: /dev/vdb
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf] Traceback (most recent call last):
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]   File "/usr/lib/python2.7/site-packages/nova/virt/libvirt/driver.py", line 1105, in attach_volume
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]     encryption)
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]   File "/usr/lib/python2.7/site-packages/nova/virt/libvirt/driver.py", line 1057, in _get_volume_encryptor
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]     **encryption)
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]   File "/usr/lib/python2.7/site-packages/nova/volume/encryptors/__init__.py", line 34, in get_volume_encryptor
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]     encryptor = nop.NoOpEncryptor(connection_info, **kwargs)
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]   File "/usr/lib/python2.7/site-packages/nova/volume/encryptors/nop.py", line 33, in __init__
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]     super(NoOpEncryptor, self).__init__(connection_info, **kwargs)
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]   File "/usr/lib/python2.7/site-packages/nova/volume/encryptors/base.py", line 38, in __init__
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]     self._key_manager = keymgr.API()
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]   File "/usr/lib/python2.7/site-packages/nova/keymgr/__init__.py", line 33, in API
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]     return cls()
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]   File "/usr/lib/python2.7/site-packages/nova/keymgr/conf_key_mgr.py", line 58, in __init__
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]     raise ValueError(_('keymgr.fixed_key not defined'))
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf] ValueError: keymgr.fixed_key not defined
2015-12-27 05:19:31.467 15447 ERROR nova.virt.libvirt.driver [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf]
2015-12-27 05:19:31.506 15447 ERROR nova.virt.block_device [req-0f3bcbfd-ae0c-4636-9b15-ba624abda9cf b68123435e544ca2ab7edb337b4b22e0 098a8690f3fe4a059d88b06415ece74c - - -] [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf] Driver failed to attach volume b589d3f9-1812-454c-b62b-73bbf388400e at /dev/vdb
2015-12-27 05:19:31.506 15447 ERROR nova.virt.block_device [instance: ce421ad3-132c-4b79-91bd-df1c1eb705bf] Traceback (most recent call last):



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 bkopilov 2015-12-28 03:01 EST
Created attachment 1109966 [details]
nova logs (compute)
Comment 5 Hugh Brock 2016-02-05 10:19:21 EST
Dan Smith suggests: "maybe set keymgr.api_class to       nova.keymgr.key_mgr.KeyManager "

However, we need to know if reporter was trying to attach an encrypted volume, or any old volume. If the second thing, this is a blocker -- if the first, not a blocker.

Benny, can you tell us whether this was an encrypted or an unencrypted volume?
Comment 6 Hugh Brock 2016-02-05 10:20:05 EST
Dan Smith suggests: "maybe set keymgr.api_class to       nova.keymgr.key_mgr.KeyManager "

However, we need to know if reporter was trying to attach an encrypted volume, or any old volume. If the second thing, this is a blocker -- if the first, not a blocker.

Benny, can you tell us whether this was an encrypted or an unencrypted volume?
Comment 7 bkopilov 2016-02-25 14:16:33 EST
It was encrypted volume as far as i know.
Benny
Comment 8 James Slagle 2016-03-21 15:35:32 EDT
(In reply to Hugh Brock from comment #5)
> Dan Smith suggests: "maybe set keymgr.api_class to      
> nova.keymgr.key_mgr.KeyManager "
> 
> However, we need to know if reporter was trying to attach an encrypted
> volume, or any old volume. If the second thing, this is a blocker -- if the
> first, not a blocker.
> 
> Benny, can you tell us whether this was an encrypted or an unencrypted
> volume?

it was an encrypted volume, not a blocker
Comment 9 Mike Burns 2016-04-07 17:00:12 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 11 Sven Anderson 2017-05-17 10:03:45 EDT
Is this still an issue? How can it be reproduced?
Comment 13 Lee Yarwood 2017-09-27 07:20:07 EDT

*** This bug has been marked as a duplicate of bug 1478161 ***

Note You need to log in before you can comment on or make changes to this bug.