Bug 129445 - BUG() on joining
BUG() on joining
Status: CLOSED WORKSFORME
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-09 05:40 EDT by Christine Caulfield
Modified: 2010-01-11 21:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-09 06:03:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christine Caulfield 2004-08-09 05:40:20 EDT
Reported by Lazar Obradovic <laza@yu.net>

CMAN: Waiting to join or form a Linux-cluster
CMAN: sending membership request
CMAN: got node new-noc
Got ENDTRANS from a node not the master: master: 6, sender: 1
CMAN: node new-noc is not responding - removing from the cluster
------------[ cut here ]------------
kernel BUG at /usr/src/cvs/cluster/cman-kernel/src/membership.c:2892!
invalid operand: 0000 [#1]
PREEMPT SMP
Modules linked in: ipv6 qla2300 qla2xxx ohci_hcd gfs lock_dlm
lock_harness dlm cman
CPU:    2
EIP:    0060:[<f885c669>]    Tainted: GF
EFLAGS: 00010246   (2.6.7-gentoo-r11)
EIP is at elect_master+0x2a/0x41 [cman]
eax: 00000080   ebx: 00000080   ecx: f88a4000   edx: 00000000
esi: f8870c08   edi: f8870c00   ebp: f7139fc0   esp: f7139f90
ds: 007b   es: 007b   ss: 0068
Process cman_memb (pid: 7327, threadinfo=f7138000 task=c22ed1e0)
Stack: f7afdb28 f8859d34 f7139fa4 00000001 f8858883 f7bf7494 fffffffb
00000000
       f7138000 0000001f 00000000 c0103fb6 00000000 c22ed1e0 c01176e2
00100100
       00200200 00000000 00000000 00000000 f88584d8 00000000 00000000
00000000
Call Trace:
 [<f8859d34>] a_node_just_died+0x130/0x181 [cman]
 [<f8858883>] membership_kthread+0x3ab/0x3e4 [cman]
 [<c0103fb6>] ret_from_fork+0x6/0x14
 [<c01176e2>] default_wake_function+0x0/0x12
 [<f88584d8>] membership_kthread+0x0/0x3e4 [cman]
 [<c01022a1>] kernel_thread_helper+0x5/0xb

Code: 0f 0b 4c 0b a0 51 86 f8 31 c0 5b c3 8b 44 24 08 89 10 8b 42


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

This maybe specific to his multicast setup, I'm not sure.
Comment 1 Christine Caulfield 2004-09-09 06:03:53 EDT
email from  Lazar:

"Well, I haven't been able to reproduce that any longer. It seems it's
two-node related, since it stopped happening when I added more nodes. As
far as I'm concerned, you may close the bug, and someone else might
reopen it if this is still happening..."
Comment 2 Kiersten (Kerri) Anderson 2004-11-16 14:13:46 EST
Updating version to the right level in the defects.  Sorry for the storm.

Note You need to log in before you can comment on or make changes to this bug.