Bug 1294471 - file /usr/lib/debug/usr/lib64/libpolkit-qt5-agent-1.so.1.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
file /usr/lib/debug/usr/lib64/libpolkit-qt5-agent-1.so.1.debug from install o...
Status: CLOSED DUPLICATE of bug 1322599
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 06:30 EST by Sudhir Khanger
Modified: 2016-11-30 04:46 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-30 04:46:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sudhir Khanger 2015-12-28 06:30:32 EST
Description of problem:

Error: Transaction check error:
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-agent-1.so.1.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-agent-1.so.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-core-1.so.1.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-core-1.so.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-gui-1.so.1.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-gui-1.so.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Sudhir Khanger 2016-02-28 21:37:18 EST
Can we please have these conflicts resolved.

  file /usr/lib/debug/usr/lib64/libpolkit-qt5-agent-1.so.1.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-agent-1.so.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-core-1.so.1.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-core-1.so.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-gui-1.so.1.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
  file /usr/lib/debug/usr/lib64/libpolkit-qt5-gui-1.so.debug from install of polkit-qt5-1-debuginfo-0.103.0-6.20130415gitbac771e.fc23.x86_64 conflicts with file from package polkit-qt-debuginfo-0.112.0-5.fc23.x86_64
Comment 2 Rex Dieter 2016-02-29 09:08:23 EST
polkit-qt5-1 is an obsolete package, dnf should not be trying to pull it into the transaction.

(yum-based debuginfo-install does not suffer from this problem)
Comment 3 Rex Dieter 2016-02-29 09:12:42 EST
reassigning to dnf-plugins-core
Comment 4 Rex Dieter 2016-02-29 09:27:10 EST
It looks like the polkit-qt5-1 subpkg from polkit-qt doesn't explicitly include any 
Obsoletes:
tags, but I wonder if adding them could help here.  I'll do so now.
Comment 5 Rex Dieter 2016-02-29 13:54:59 EST
polkit-qt:

* Mon Feb 29 2016 Rex Dieter <rdieter@fedoraproject.org> - 0.112.0-7
- pull in some upstream fixes
- -qt5: Obsoletes: polkit-qt5-1 (#1294471)
Comment 6 Rex Dieter 2016-02-29 13:57:29 EST
alternative workaround that may help, add
exclude=polkit-qt5-1*
to
/etc/yum.repos.d/fedora.repo:
under
[fedora-debuginfo]
section
Comment 7 Sudhir Khanger 2016-02-29 22:58:10 EST
I ended up removing polkit-qt-debuginfo so as to install polkit-qt5-1.

Removing polkit-qt5-1 tries to remove a whole lot of things. https://paste.fedoraproject.org/331482/
Comment 8 Rex Dieter 2016-03-01 09:46:25 EST
yeah, you clearly don't want to remove polkit-qt5-1, but what you *do* want to do is to avoid installing polkit-qt5-1-debuginfo (and use the newer polkit-qt-debuginfo instead)
Comment 9 Fedora Update System 2016-03-01 09:48:09 EST
polkit-qt-0.112.0-7.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-47408e3719
Comment 10 Fedora Update System 2016-03-02 07:52:31 EST
polkit-qt-0.112.0-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-47408e3719
Comment 11 Fedora Update System 2016-03-03 15:23:42 EST
polkit-qt-0.112.0-7.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Rex Dieter 2016-03-08 12:40:33 EST
Didn't seem to help in my own testing, just tried:

dnf debuginfo-install kcalc

today, and it (still) tries to pull polkit-qt5-1-debuginfo into the transaction
Comment 13 Honza Silhan 2016-03-14 08:18:32 EDT
Can you attach debugdata [1], please?

[1] https://github.com/rpm-software-management/dnf/wiki/Bug-Reporting#dependency-resolution-problem
Comment 14 Fedora Admin XMLRPC Client 2016-07-08 05:25:44 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 15 Jaroslav Mracek 2016-09-20 03:14:13 EDT
Can you attach debugdata [1], please?

[1] https://github.com/rpm-software-management/dnf/wiki/Bug-Reporting#dependency-resolution-problem
Comment 16 Igor Gnatenko 2016-09-20 04:14:07 EDT
Basically we should not install debuginfo for deps.
Comment 17 Fedora End Of Life 2016-11-24 09:33:18 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 18 Igor Gnatenko 2016-11-30 04:46:39 EST

*** This bug has been marked as a duplicate of bug 1322599 ***

Note You need to log in before you can comment on or make changes to this bug.