Bug 1294493 - No module named mistralclient.api
No module named mistralclient.api
Status: CLOSED DUPLICATE of bug 1294494
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Zane Bitter
Amit Ugol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 08:28 EST by Ronnie Rasouli
Modified: 2016-04-26 17:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 09:53:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronnie Rasouli 2015-12-28 08:28:14 EST
Description of problem:

Deployment fails with error, in controller heat-engine.log there are errors of missing mistral module 

Version-Release number of selected component (if applicable):

RHOS8 release 2015-12-03-1

heat-cfntools-1.2.8-2.el7.noarch
openstack-heat-engine-5.0.0-1.el7ost.noarch
python-heatclient-0.8.0-1.el7ost.noarch
openstack-heat-api-cfn-5.0.0-1.el7ost.noarch
openstack-heat-common-5.0.0-1.el7ost.noarch
openstack-heat-api-cloudwatch-5.0.0-1.el7ost.noarch
openstack-heat-api-5.0.0-1.el7ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. deploy rhos8 by the procedure detailed: http://file.tlv.redhat.com/~rrasouli/rhos8
2.overcloud post deploy failed code 6, login to the one of the HA controllers
3.look for errors in /var/log/heat* log

Actual results:

Deployment failed

Expected results:

Pre and post deployment should pass, no errors of missing modules.

Additional info:
2015-12-28 03:49:26.476 4825 ERROR stevedore.extension [-] Could not load 'mistral': No module named mistralclient.api
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension [-] No module named mistralclient.api
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension Traceback (most recent call last):
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 162, in _load_plugins
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension     verify_requirements,
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/enabled.py", line 67, in _load_one_plugin
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension     verify_requirements,
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 185, in _load_one_plugin
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension     plugin = ep.load(require=verify_requirements)
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension     entry = __import__(self.module_name, globals(),globals(), ['__name__'])
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/heat/engine/clients/os/mistral.py", line 14, in <module>
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension     from mistralclient.api import base as mistral_base
2015-12-28 03:49:26.478 4825 ERROR stevedore.extension ImportError: No module named mistralclient.api
Comment 2 Ronnie Rasouli 2015-12-28 09:53:49 EST

*** This bug has been marked as a duplicate of bug 1294494 ***

Note You need to log in before you can comment on or make changes to this bug.