Bug 1294515 - (PATCH AVAILABLE) binomial_heap data corruption
(PATCH AVAILABLE) binomial_heap data corruption
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jonathan Wakely
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 11:44 EST by Avi Kivity
Modified: 2016-01-19 18:27 EST (History)
4 users (show)

See Also:
Fixed In Version: boost-1.58.0-11.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 18:27:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch curl'ed from boost's git repository (1.11 KB, patch)
2015-12-28 11:44 EST, Avi Kivity
no flags Details | Diff

  None (edit)
Description Avi Kivity 2015-12-28 11:44:54 EST
Created attachment 1110044 [details]
Patch curl'ed from boost's git repository

Description of problem:

binomial_heap will corrupt its internal data structure after many operations.


Version-Release number of selected component (if applicable):
boost-1.58.0-9.fc23.x86_64

How reproducible:
Always

Steps to Reproduce:
1.  See https://github.com/scylladb/scylla/issues/698 for a complex reproducer

Actual results:

Infinite loop due to corrupted heap structure


Expected results:

Finite loop due to correct data structures.

Additional info:

Already fixed, see https://github.com/boostorg/heap/commit/8091fbf00ae6953d34b717ab077a041420e5ba43
Comment 1 Fedora Update System 2016-01-15 15:37:29 EST
boost-1.58.0-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-901d712d1b
Comment 2 Fedora Update System 2016-01-17 09:22:46 EST
boost-1.58.0-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-901d712d1b
Comment 3 Fedora Update System 2016-01-19 18:27:33 EST
boost-1.58.0-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.