Bug 129453 - Switching locale for Norwegian bokmÃ¥l
Switching locale for Norwegian bokmål
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-09 08:40 EDT by Kjartan Maraas
Modified: 2014-03-16 22:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 15:57:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2004-08-09 08:40:17 EDT
Description of problem:

I want to switch the norwegian bokmål locale from using no_NO to the
correct nb_NO soon and I wanted to hear what the best way to do this
would be from a distro perspective. In the translations I manage
upstream I'm probably just going to add nb.no to the modules and start
 removing no.po as soon as I've verified that the new locale works
correctly, but I don't have the necessary access to Fedora's CVS to do
this myself here.

Could someone run a script to rename/copy the no.po files to nb.po?
Can we live with both for one cycle to get some time to verify that
the new one works?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2004-08-10 12:25:18 EDT
Does nb_NO work in glibc?

Is no_NO an alias?
Comment 2 Bill Nottingham 2004-08-10 12:49:45 EDT
Kjartaan - are you willing to do the upstream gnome work? :)
Comment 3 Kjartan Maraas 2004-08-10 13:07:36 EDT
I'll do the GNOME part by adding nb.po as a copy of no.po for now.
I'll remove no.po over the next development cycle when I'm certain
that nb_NO works as planned. I think nb_NO was added as a full locale,
so they're both equal in that sense. You'll have to check glibc to be
sure though.
Comment 4 Bill Nottingham 2004-09-01 23:08:41 EDT
Realizing this slipped through at the moment.

The proper steps would be:

1) copy all the po files on elvis
2) fix the i18n-access to allow translator access to nb
3) change the lang-table in anaconda
4) change no_NO in glibc to be an alias (to match upstream)

I'll work on #1.
Comment 5 Jeremy Katz 2004-09-01 23:13:27 EDT
I'll get #3
Comment 6 Bill Nottingham 2004-09-02 00:22:16 EDT
#1 done.
Comment 7 Paul Gampe 2004-09-02 00:41:44 EDT
nb_NO has been in our glibc-common since version 2.3.3-1, so good to 
go there. Here is Jakub's comment: 
 
* Tue Dec 02 2003 Jakub Jelinek <jakub@redhat.com> 2.3.3-1 
 
... 
 
- for the time being, include both nb_NO* and no_NO* as locales 
  so that the distribution can catch up with the no_NO->nb_NO 
  transition 
 
Sarah can you please update the translator database to give Kjartan 
access to this locale? 
 
Comment 8 Jeremy Katz 2004-09-02 12:38:46 EDT
And #3 is done as well
Comment 9 Kjartan Maraas 2004-09-02 15:45:14 EDT
Do I need to add something like this to gdm?

diff -u -r1.37 locale.alias
--- locale.alias        3 Aug 2004 23:48:55 -0000       1.37
+++ locale.alias        2 Sep 2004 19:47:38 -0000
@@ -67,7 +67,7 @@
 Malay                  ms_MY.UTF-8,ms_MY
 Marathi                        mr_IN.UTF-8,mr_IN
 Mongolian              mn_MN.UTF-8,mn_MN
-Norwegian(bokmal)      no_NO.UTF-8,no_NO
+Norwegian(bokmal)      no_NO.UTF-8,no_NO,nb_NO.UTF-8,nb_NO
 Norwegian(nynorsk)     nn_NO.UTF-8,nn_NO
 Oriya                  or_IN.UTF-8,or_IN
 Panjabi                        pa_IN.UTF-8,pa_IN
Comment 10 Bill Nottingham 2004-09-02 15:49:46 EDT
Wouldn't you want that reversed? (To prefer nb_NO...)
Comment 11 Kjartan Maraas 2004-09-02 15:55:56 EDT
Didn't know that there was a preferred order really. I mailed the
maintainer about this earlier today but haven't gotten an answer. I'll
reverse it if that makes sense of course :) I wonder how many other
places there are like this in the distro :-/
Comment 12 Bill Nottingham 2004-09-02 16:00:22 EDT
I don't know that there *is* a preferred order, but I'd assume that's
why the UTF-8 ones are first.
Comment 13 Kjartan Maraas 2004-09-13 12:13:06 EDT
I still haven't gotten permission to commit for the nb_NO locale it
seems. Sarah?
Comment 14 Bill Nottingham 2004-10-11 15:29:01 EDT
Kjartan - do you have access now?
Comment 15 Bill Nottingham 2004-10-11 15:52:51 EDT
I just fixed a bug in anaconda so that it defaults correctly to nb_NO
for the installed system. With this, this should be fixed.
Comment 16 Kjartan Maraas 2004-10-11 16:08:32 EDT
I have gotten access, but I was thrown off by not being able to commit
no.po any longer. I understand that this is not needed anyway so I'm
fine with the current status.

The only thing I know of now is preferring nb_NO in gdm's locale.alias
copy. I commited this upstream, but no release has been made since.
I've also posted a call for tarballs for GNOME 2.8.1, so I'll wait and
see what releases that trigger...

Thanks all.
Comment 17 Bill Nottingham 2004-10-11 16:18:57 EDT
Please open a separate bug for gdm in RH's bugzilla, so we can make
sure we get the fix in even if the new upstream release is late.

Note You need to log in before you can comment on or make changes to this bug.