Bug 1294539 - pacemaker-1.1.13-10.el7.x86_64 breaks /tmp/ha-all-in-one-util.bash in OSP 6 foreman installation [NEEDINFO]
pacemaker-1.1.13-10.el7.x86_64 breaks /tmp/ha-all-in-one-util.bash in OSP 6 f...
Status: CLOSED DUPLICATE of bug 1290684
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer (Show other bugs)
6.0 (Juno)
x86_64 Linux
high Severity high
: ---
: 6.0 (Juno)
Assigned To: Jason Guiditta
Shai Revivo
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 16:52 EST by Matt Flusche
Modified: 2016-06-14 03:15 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-14 03:15:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mburns: needinfo? (nbarcet)
mburns: needinfo? (jcoufal)


Attachments (Terms of Use)

  None (edit)
Description Matt Flusche 2015-12-28 16:52:47 EST
Description of problem:

In pacemaker-1.1.13-10.el7.x86_64, the output of `crm_node -l` has changed.  The additional output breaks /tmp/ha-all-in-one-util.bash during the openstack deployment.

New output (1.1.13-10.el7):

# crm_node  -l
2 pcmk-rhosp-2 member
1 pcmk-rhosp-1 member
3 pcmk-rhosp-3 member

Old output (<= pacemaker-1.1.12-22.el7_1.2)

# crm_node -l
2 pcmk-rhosp-2
1 pcmk-rhosp-1
3 pcmk-rhosp-3

Debug from ha-all-in-one-util.bash running with version 1.1.13-10.el7 of pacemaker

# sudo bash -x /tmp/ha-all-in-one-util.bash all_members_include haproxy
> + keystone_private_vip=10.255.76.249
> + [[ 2 -lt 1 ]]
> + case "$1" in
> + all_members_include haproxy
> + element=haproxy
> ++ /usr/sbin/crm_node -l
> ++ perl -p -e 's/^.*\s+(\S+)$/$1/g'
> + members='member
> member
> member'
> + '[' 'xmember
> member
> member' = x ']'
> + for member in '$members'
> + property_includes member haproxy
> ++ get_property_value member
> ++ /bin/grep member
> ++ perl -p -e 's/^.*\: //'
> +++ get_property member
> +++ /usr/sbin/pcs property show member
> ++ echo Cluster Properties:
> + propval=
> + element=haproxy
> + echo
> + /bin/grep -q haproxy
> + return 1


Version-Release number of selected component (if applicable):
pacemaker-1.1.13-10.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Deploy openstack with foreman installer (OSP 6) and pacemaker-1.1.13-10.el7.x86_64
2. 
3.

Actual results:
Installation fails

Expected results:
Installation successful

Additional info:
Comment 4 Kari Hautio 2016-06-14 02:55:16 EDT
Just a quick note that this has been fixed into RHELOSP 6.0 (sane as BZ #1290684)

rpm -q --changelog openstack-foreman-installer-3.0.27-1.el7ost.noarch | head
* Tue Jan 12 2016 Jason Guiditta <jguiditt@redhat.com> 3.0.27-1
- BZ #1290684 - Replace regex to accommodate change in crm_mode output.
- BZ #1292555 - Remove operator access from command.
Comment 5 GE Scott Knauss 2016-06-14 03:15:53 EDT

*** This bug has been marked as a duplicate of bug 1290684 ***

Note You need to log in before you can comment on or make changes to this bug.