Bug 1294545 - SELinux is preventing python3 from 'open' accesses on the file /usr/lib/python3.4/site-packages/zgitignore-0.7.1-py3.4.egg.
SELinux is preventing python3 from 'open' accesses on the file /usr/lib/pytho...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:8d899cefb73166e06cc664ef5e6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 17:52 EST by Javier
Modified: 2016-03-31 03:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-02 07:35:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier 2015-12-28 17:52:45 EST
Description of problem:
Report from SELinux after installing OneDrive 
SELinux is preventing python3 from 'open' accesses on the file /usr/lib/python3.4/site-packages/zgitignore-0.7.1-py3.4.egg.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/usr/lib/python3.4/site-packages/zgitignore-0.7.1-py3.4.egg default label should be lib_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /usr/lib/python3.4/site-packages/zgitignore-0.7.1-py3.4.egg

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that python3 should be allowed open access on the zgitignore-0.7.1-py3.4.egg file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep python3 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:blueman_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_tmp_t:s0
Target Objects                /usr/lib/python3.4/site-
                              packages/zgitignore-0.7.1-py3.4.egg [ file ]
Source                        python3
Source Path                   python3
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-158.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.8-300.fc23.i686 #1 SMP Tue Dec
                              15 17:30:11 UTC 2015 i686 i686
Alert Count                   2
First Seen                    2015-12-28 16:42:10 CST
Last Seen                     2015-12-28 16:42:10 CST
Local ID                      ed9b6201-93b4-4654-8697-fdcb8d7d968b

Raw Audit Messages
type=AVC msg=audit(1451342530.425:594): avc:  denied  { open } for  pid=2072 comm="python3" path="/usr/lib/python3.4/site-packages/zgitignore-0.7.1-py3.4.egg" dev="dm-0" ino=1189370 scontext=system_u:system_r:blueman_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file permissive=0


Hash: python3,blueman_t,user_tmp_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-158.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.8-300.fc23.i686
type:           libreport
Comment 1 Daniel Walsh 2016-01-02 07:35:42 EST
You have mislabeled content in /usr.

restorecon -R -v /usr

Should fix.

This looks like some content was created in /tmp and then mv'd into /usr/lib/python3.4...

Not sure how this happened.
Comment 2 Daniel Kelly 2016-03-27 01:10:51 EDT
Description of problem:
logging in with cinnamon desktop, after updatiing selinux policy to version 3.13.1-158.11


Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.4.6-300.fc23.x86_64
type:           libreport
Comment 3 Daniel Kelly 2016-03-31 03:10:08 EDT
Description of problem:
happened during login, cinnamon desktop


Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.4.6-300.fc23.x86_64
type:           libreport

Note You need to log in before you can comment on or make changes to this bug.