Bug 1294605 - "lvconvert“ man page needs correction
Summary: "lvconvert“ man page needs correction
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.4
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: David Teigland
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-29 08:52 UTC by ajit mote
Modified: 2019-10-10 10:47 UTC (History)
11 users (show)

Fixed In Version: lvm2-2.02.161-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 04:13:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Description ajit mote 2015-12-29 08:52:54 UTC
Description of problem:
"lvconvert“ man page needs correction in examples provided : 

In the "OPTIONS“ section the entry for "-m, --mirrors Mirrors“ says:

  The default mirroring segment type is "raid1". If the legacy "mirror"
  segment type is desired, the --type argument must be used to
  explicitly select the desired type.

The "Examples“ section contains many examples that contradict this,
for example the first two:

1. Converts the linear logical volume "vg00/lvol1" to a two-way mirror
   logical volume:
     lvconvert -m1 vg00/lvol1

This should probably be:
     lvconvert --type mirror -m1 vg00/lvol1

2. Converts the linear logical volume "vg00/lvol1" to a two-way RAID1
   logical volume:
     lvconvert --type raid1 -m1 vg00/lvol1

This should probably be:
     lvconvert -m1 vg00/lvol1

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 

How reproducible:
Always

Steps to Reproduce:
1. go through man page of lvconvert

Actual results:
Default mirroring segment type is raid but examples provided shows different.

Expected results:
Correct examples as above.

Additional info:
This documentation man page change needs correction in RHEL6 as well.

Comment 3 Peter Rajnoha 2016-06-06 13:59:01 UTC
What is used by default depends on the options given to "configure" before compiling sources. In RHEL6, this is "configure ----with-default-mirror-segtype=mirror --with-default-raid10-segtype=mirror" while in RHEL7 the "raidN" types are used instead.

So any man page should be written in a way that it's clear which type is used at the moment - it should simply reference the global/mirror_segtype_default and global/raid10_segtype_default settings and not name any concrete type unless --type mirror/raidN is specified (there is also global/sparse_segtype_default setting which is similar).

Comment 4 Peter Rajnoha 2016-07-12 13:40:06 UTC
The lvconvert man page has been completely rewritten recently and it contains proper reference to either mirror or raid1 so it's always clear which one is used (scheduled for upcoming upstream lvm2 v2.02.161 release):

https://git.fedorahosted.org/cgit/lvm2.git/commit/?id=7771793a560b839e6bc4083819bc5b192d94835a

https://git.fedorahosted.org/cgit/lvm2.git/commit/?id=c526c327d7352e60eb19a739a2f394e2744c5629

https://git.fedorahosted.org/cgit/lvm2.git/commit/?id=589b752eeb6b442f2987b1cd1736f8f461c9aa95

https://git.fedorahosted.org/cgit/lvm2.git/commit/?id=12ecd95965321af194c3d446c0b5205d90994522

Comment 6 Corey Marthaler 2016-08-01 20:05:20 UTC
Marking verified in the latest rpms. Both mentioned linear converts specify the '--type' now.


Examples
       Convert a linear LV to a two-way mirror LV:
       lvconvert --type mirror --mirrors 1 vg/lvol1

       Convert a linear LV to a two-way RAID1 LV:
       lvconvert --type raid1 --mirrors 1 vg/lvol1



3.10.0-480.el7.x86_64
lvm2-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
lvm2-libs-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
lvm2-cluster-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-libs-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-event-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-event-libs-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-persistent-data-0.6.3-1.el7    BUILT: Fri Jul 22 05:29:13 CDT 2016
cmirror-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
sanlock-3.3.0-1.el7    BUILT: Wed Feb 24 09:52:30 CST 2016
sanlock-lib-3.3.0-1.el7    BUILT: Wed Feb 24 09:52:30 CST 2016
lvm2-lockd-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016

Comment 8 errata-xmlrpc 2016-11-04 04:13:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.