Bug 1294608 - quota: limit xattr not healed for a sub-directory on a newly added bricks
quota: limit xattr not healed for a sub-directory on a newly added bricks
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: 3.7.5
: ---
Assigned To: Vijaikumar Mallikarjuna
: ZStream
Depends On: 1294478 1294479
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 04:12 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:49 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294479
Environment:
Last Closed: 2016-04-19 03:52:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-29 04:13:05 EST
REVIEW: http://review.gluster.org/13108 (quota: limit xattr for subdir not healed on newly added bricks) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-01-06 06:54:39 EST
REVIEW: http://review.gluster.org/13108 (quota: limit xattr for subdir not healed on newly added bricks) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2016-01-26 01:26:42 EST
COMMIT: http://review.gluster.org/13108 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit d93ed64f65f7680cb25068cfae1844de44ca39b7
Author: vmallika <vmallika@redhat.com>
Date:   Mon Dec 28 17:33:26 2015 +0530

    quota: limit xattr for subdir not healed on newly added bricks
    
    This is a backport of http://review.gluster.org/#/c/13100/
    
    DHT after creating missing directory, tries to heal the
    xattrs. This xattrs operation fails as INTERNAL FOP key was not set
    
    > Change-Id: I819d373cf7073da014143d9ada908228ddcd140c
    > BUG: 1294479
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I30345e919bc9ae882fd0e159c7b03ffc50ed5ef7
    BUG: 1294608
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13108
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Kaushal 2016-04-19 03:52:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.