Bug 1294626 - Path too long error on unzipping the patch using Extract All on Windows Server 2008 R2
Path too long error on unzipping the patch using Extract All on Windows Serve...
Status: CLOSED ERRATA
Product: JBoss Operations Network
Classification: JBoss
Component: Productization (Show other bugs)
JON 3.3.5
Unspecified Unspecified
high Severity high
: DR01
: JON 3.3.9
Assigned To: Simeon Pinder
Filip Brychta
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 05:32 EST by Sunil Kondkar
Modified: 2017-10-02 13:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-02 13:21:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (18.24 KB, image/png)
2015-12-29 05:32 EST, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2015-12-29 05:32:24 EST
Created attachment 1110138 [details]
Screenshot

Description of problem:

Tried to unzip the patch on Windows Server 2008 R2 using Extract All and specified "C:\" directory as extraction root dir.

While extracting, it shows path too long error for file 'CallTimeDataConverterValidator.class'. Please refer the attached screenshot.

Version-Release number of selected component (if applicable):

OS: Windows server 20008 R2
Build: JON 3.3.5 DR01 build

How reproducible:
Always

Steps to Reproduce:

1) Download the JON 3.3.5 DR01 patch from:
http://download.devel.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/72/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip
2) On Windows 2008 R2, try to unzip jon-server-patch-3.3.0.GA.zip using Extract All
3) Specify "C:\" directory as extraction root dir.
4) It shows the path too long error for file 'CallTimeDataConverterValidator.class'.

Actual results:

Path too long error for file 'CallTimeDataConverterValidator.class' while extracting the patch.

Expected results:
No errors.

Additional info:
Comment 1 Sunil Kondkar 2016-01-04 10:07:43 EST
Adding some more info:

This issue exists in JON3.3.4 as well if we use Extract All to unzip the patch.

If we use cygwin unzip, the issue does not exist in JON3.3.4 and JON3.3.5DR01 and unzip works without error.
Comment 2 Filip Brychta 2016-01-08 09:18:07 EST
For documentation:
Some windows compression tools have problems with file path names longer than 256 characters (probably general problem for all tools using MAX_PATH - https://support.microsoft.com/en-us/kb/177665)

Tested tools which are affected:
- winrar 4.20
- winzip 20
- integrated windows explorer in Windowns server 2008 R2

Tested tools which are not affected:
- cygwin
- 7-zip
Comment 3 Josejulio Martínez 2016-04-19 11:46:02 EDT
Could it be related to this: https://support.microsoft.com/en-us/kb/2891362 ?
If so, there is Hotfix for Windows Server 2008 R2.
Comment 11 Simeon Pinder 2017-09-01 11:33:59 EDT
Moving to ON_QA as available for test with the following binary:
http://download.eng.bos.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/133/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip

*NOTE Build represents JON 3.3.9 DR01 build.

Please report issues as you encounter them.
Comment 14 errata-xmlrpc 2017-10-02 13:21:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2846

Note You need to log in before you can comment on or make changes to this bug.