Bug 1294647 - [abrt] kf5-kglobalaccel: qt_message_fatal(): kglobalaccel5 killed by SIGABRT
[abrt] kf5-kglobalaccel: qt_message_fatal(): kglobalaccel5 killed by SIGABRT
Status: CLOSED DUPLICATE of bug 1211075
Product: Fedora
Classification: Fedora
Component: kf5-kglobalaccel (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:cd73fd0d55ba0d76d3a23bf986e...
:
: 1341725 1354215 1354217 1360189 1361849 1373283 1407005 1435869 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 07:28 EST by Mustafa Muhammad
Modified: 2017-03-25 01:58 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-11 10:06:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (18.83 KB, text/plain)
2015-12-29 07:28 EST, Mustafa Muhammad
no flags Details
File: cgroup (259 bytes, text/plain)
2015-12-29 07:28 EST, Mustafa Muhammad
no flags Details
File: core_backtrace (4.74 KB, text/plain)
2015-12-29 07:28 EST, Mustafa Muhammad
no flags Details
File: dso_list (8.49 KB, text/plain)
2015-12-29 07:28 EST, Mustafa Muhammad
no flags Details
File: environ (1.63 KB, text/plain)
2015-12-29 07:29 EST, Mustafa Muhammad
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-29 07:29 EST, Mustafa Muhammad
no flags Details
File: maps (37.82 KB, text/plain)
2015-12-29 07:29 EST, Mustafa Muhammad
no flags Details
File: mountinfo (3.51 KB, text/plain)
2015-12-29 07:29 EST, Mustafa Muhammad
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-29 07:29 EST, Mustafa Muhammad
no flags Details
File: open_fds (135 bytes, text/plain)
2015-12-29 07:29 EST, Mustafa Muhammad
no flags Details
File: proc_pid_status (1.17 KB, text/plain)
2015-12-29 07:29 EST, Mustafa Muhammad
no flags Details
File: var_log_messages (331 bytes, text/plain)
2015-12-29 07:29 EST, Mustafa Muhammad
no flags Details

  None (edit)
Description Mustafa Muhammad 2015-12-29 07:28:44 EST
Version-Release number of selected component:
kf5-kglobalaccel-5.17.0-1.fc24

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/kglobalaccel5
crash_function: qt_message_fatal
executable:     /usr/bin/kglobalaccel5
global_pid:     3255
kernel:         4.4.0-0.rc6.git1.1.fc24.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 qt_message_fatal at global/qlogging.cpp:1610
 #3 QMessageLogger::fatal at global/qlogging.cpp:784
 #4 QXcbConnection::QXcbConnection at qxcbconnection.cpp:559
 #5 QXcbIntegration::QXcbIntegration at qxcbintegration.cpp:177
 #6 QXcbIntegrationPlugin::create at qxcbmain.cpp:50
 #7 loadIntegration at kernel/qplatformintegrationfactory.cpp:56
 #8 QPlatformIntegrationFactory::create at kernel/qplatformintegrationfactory.cpp:73
 #9 init_platform at kernel/qguiapplication.cpp:1032
 #10 QGuiApplicationPrivate::createPlatformIntegration at kernel/qguiapplication.cpp:1199
 #11 QGuiApplicationPrivate::createEventDispatcher at kernel/qguiapplication.cpp:1216

Potential duplicate: bug 1229360
Comment 1 Mustafa Muhammad 2015-12-29 07:28:52 EST
Created attachment 1110203 [details]
File: backtrace
Comment 2 Mustafa Muhammad 2015-12-29 07:28:54 EST
Created attachment 1110204 [details]
File: cgroup
Comment 3 Mustafa Muhammad 2015-12-29 07:28:56 EST
Created attachment 1110205 [details]
File: core_backtrace
Comment 4 Mustafa Muhammad 2015-12-29 07:28:58 EST
Created attachment 1110206 [details]
File: dso_list
Comment 5 Mustafa Muhammad 2015-12-29 07:29:00 EST
Created attachment 1110207 [details]
File: environ
Comment 6 Mustafa Muhammad 2015-12-29 07:29:02 EST
Created attachment 1110208 [details]
File: limits
Comment 7 Mustafa Muhammad 2015-12-29 07:29:05 EST
Created attachment 1110209 [details]
File: maps
Comment 8 Mustafa Muhammad 2015-12-29 07:29:07 EST
Created attachment 1110210 [details]
File: mountinfo
Comment 9 Mustafa Muhammad 2015-12-29 07:29:09 EST
Created attachment 1110211 [details]
File: namespaces
Comment 10 Mustafa Muhammad 2015-12-29 07:29:10 EST
Created attachment 1110212 [details]
File: open_fds
Comment 11 Mustafa Muhammad 2015-12-29 07:29:12 EST
Created attachment 1110213 [details]
File: proc_pid_status
Comment 12 Mustafa Muhammad 2015-12-29 07:29:14 EST
Created attachment 1110214 [details]
File: var_log_messages
Comment 13 Jan Kurik 2016-02-24 09:11:15 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 14 Alvin 2016-05-11 09:57:07 EDT
Similar problem has been detected:

Log in
plasmashell does not start or immediately crashes.
Closing a window leaves an image of that window on the screen
Moving a window leaves an image of that window on the screen

reporter:       libreport-2.7.0
backtrace_rating: 4
cmdline:        /usr/bin/kglobalaccel5
crash_function: qt_message_fatal
executable:     /usr/bin/kglobalaccel5
global_pid:     2477
kernel:         4.5.3-300.fc24.x86_64
package:        kf5-kglobalaccel-5.21.0-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         kglobalaccel5 killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1001
Comment 15 Rex Dieter 2016-05-11 10:06:40 EDT
#3  QMessageLogger::fatal (this=this@entry=0x7ffd0deb2130, msg=msg@entry=0x7f38abc89ef0 "QXcbConnection: Could not connect to display %s") at global/qlogging.cpp:784

*** This bug has been marked as a duplicate of bug 1211075 ***
Comment 16 Sylvain Réault 2016-06-01 11:17:31 EDT
*** Bug 1341725 has been marked as a duplicate of this bug. ***
Comment 17 Mario Curcija 2016-07-10 16:39:38 EDT
*** Bug 1354215 has been marked as a duplicate of this bug. ***
Comment 18 Mario Curcija 2016-07-10 18:09:56 EDT
*** Bug 1354217 has been marked as a duplicate of this bug. ***
Comment 19 Michele Cereda 2016-07-26 04:00:43 EDT
*** Bug 1360189 has been marked as a duplicate of this bug. ***
Comment 20 David W. Legg 2016-07-31 04:31:36 EDT
*** Bug 1361849 has been marked as a duplicate of this bug. ***
Comment 21 Charles Dennett 2016-09-05 14:08:40 EDT
*** Bug 1373283 has been marked as a duplicate of this bug. ***
Comment 22 Michal Smolak 2016-12-21 23:41:21 EST
*** Bug 1407005 has been marked as a duplicate of this bug. ***
Comment 23 ruedberued 2017-03-25 01:58:58 EDT
*** Bug 1435869 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.