Bug 1294659 - Packstack installation failed when using IPv6 addresses in answer file
Packstack installation failed when using IPv6 addresses in answer file
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity urgent
: z4
: 7.0 (Kilo)
Assigned To: Martin Magr
Udi Shkalim
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 08:54 EST by Udi Shkalim
Modified: 2016-02-18 11:46 EST (History)
6 users (show)

See Also:
Fixed In Version: openstack-packstack-2015.1-0.16.dev1589.g1d6372f.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 11:46:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from packstack installation failure (6.69 KB, text/plain)
2015-12-29 08:54 EST, Udi Shkalim
no flags Details
packstack answer file (41.78 KB, text/plain)
2016-01-15 03:26 EST, Udi Shkalim
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 274747 None None None 2016-02-01 11:15 EST

  None (edit)
Description Udi Shkalim 2015-12-29 08:54:34 EST
Created attachment 1110238 [details]
log from packstack installation failure

Description of problem:
When installing openstack with IPv6 addresses installation failed with the following:
Adding Neutron Metering Agent manifest entries       [ DONE ]
Adding Neutron Metadata Agent manifest entries       [ DONE ]
Checking if NetworkManager is enabled and running    [ DONE ]
Adding OpenStack Client manifest entries             [ DONE ]
Adding Horizon manifest entries                      [ DONE ]
Adding Swift Keystone manifest entries               [ DONE ]
Adding Swift builder manifest entries             [ ERROR ]

ERROR : Unknown hostname [2001:77:77:77:f816:3eff:fe70:bf68].
Please check log file /var/tmp/packstack/20151229-083833-QXcVPI/openstack-setup.log for more information


Version-Release number of selected component (if applicable):
openstack-packstack-2015.1-0.14.dev1589.g1d6372f.el7ost.noarch
openstack-packstack-puppet-2015.1-0.14.dev1589.g1d6372f.el7ost.noarch
OSP 7.0.3


How reproducible:
100%

Steps to Reproduce:
1. Try to install packstack with IPv6 address in answer file
2.
3.

Actual results:
Installation failed

Expected results:
Installation Passed

Additional info:
log is attached.
Comment 2 Ivan Chavero 2016-01-06 01:34:47 EST
ssh needs the interface to be concatenated like this: ipv6_address%eth0

eg.

2001:77:77:77:f816:3eff:fe70:bf68%eth0

I will create a patch that identifies the network interface of the address and concatenate it to the ipv6 address
Comment 3 Ivan Chavero 2016-01-13 22:23:55 EST
After some testing i haven't been able to recreate this bug.

Can you provide more detail for the setup that is having the problem?
How are de ipv6 addresses obtained? dhcp? manually?
Comment 4 Udi Shkalim 2016-01-15 03:26:00 EST
The setup is all-in-one machine with 4 NICs. 
eth3 is the NIC with IPv6 which is DHCP IPv6 slaac

answer file is attached.
Comment 5 Udi Shkalim 2016-01-15 03:26 EST
Created attachment 1115045 [details]
packstack answer file
Comment 6 Ofer Blaut 2016-01-15 07:15:57 EST
Hi

It does work on older versions, something changed ?
Comment 8 Martin Magr 2016-02-01 09:08:10 EST
Using latest upstream version on CentOS the issue cannot be reproduced [1]. The same is for latest downstream version.

I've just noticed, that the error appeared on 7.0 version, so I'm going to retarget the bug and try to reproduce it on 7.0.

[1] http://fpaste.org/316290/86716145/
[2] http://fpaste.org/317108/35361145/
Comment 9 Martin Magr 2016-02-01 09:37:54 EST
Indeed, IPv6 support for Swift in OSP-7 is broken:

Adding Swift builder manifest entries             [ ERROR ]

ERROR : Unknown hostname [fd00::16].

I'm starting to investigate.
Comment 10 Martin Magr 2016-02-01 11:15:34 EST
There is a missing patch left to backport.
Comment 14 Udi Shkalim 2016-02-08 05:47:54 EST
Verified on:
openstack-packstack-puppet-2015.1-0.16.dev1589.g1d6372f.el7ost.noarch
openstack-packstack-2015.1-0.16.dev1589.g1d6372f.el7ost.noarch

Steps:
Installed RHOS 7
configured IPv6 interface
Edited the answer file and replaced all IPv4 to IPv6 address
Started packstack

Applying 2001:0db8:0:f101::1_nagios_nrpe.pp
2001:0db8:0:f101::1_nagios.pp:                       [ DONE ]                 
2001:0db8:0:f101::1_nagios_nrpe.pp:                  [ DONE ]                 
Applying 2001:0db8:0:f101::1_postscript.pp
2001:0db8:0:f101::1_postscript.pp:                   [ DONE ]                
Applying Puppet manifests                            [ DONE ]
Finalizing                                           [ DONE ]

 **** Installation completed successfully ******

Additional information:
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * Warning: IPv6 and ovs tunneling is not yet supported and will fail on host 2001:0db8:0:f101::1 see https://bugzilla.redhat.com/show_bug.cgi?id=1100360.
 * Warning: NetworkManager is active on 2001:0db8:0:f101::1. OpenStack networking currently does not work on systems that have the Network Manager service enabled.
 * File /root/keystonerc_admin has been created on OpenStack client host 2001:0db8:0:f101::1. To use the command line tools you need to source the file.
Comment 16 errata-xmlrpc 2016-02-18 11:46:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0265.html

Note You need to log in before you can comment on or make changes to this bug.