Bug 1294664 - Support ManageIQ Service Account and Role by default
Support ManageIQ Service Account and Role by default
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Jason DeTiberus
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 09:28 EST by Federico Simoncelli
Modified: 2016-07-03 20:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:43:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Federico Simoncelli 2015-12-29 09:28:13 EST
Description of problem:
The openshift-ansible playbooks/roles should include the support for the required ManageIQ Service Account, Role and Project.

Version-Release number of selected component (if applicable):
3.0.15-1.git.0.8e979de.el7

How reproducible:
100%

Actual results:
Currently it is not possible to deploy OpenShift with the required ManageIQ configurations (nor it's the default).

Expected results:
By default OpenShift should be deployed with the required ManageIQ configurations pre-loaded.


Additional info:
The relevant patches are currently merged/reviewed upstream:

https://github.com/openshift/openshift-ansible/pull/983
https://github.com/openshift/openshift-ansible/pull/1050
Comment 6 errata-xmlrpc 2016-01-27 14:43:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.