This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1294669 - [RFE] Web-UI: Access control element (users, groups) should honor tag visibility
[RFE] Web-UI: Access control element (users, groups) should honor tag visibility
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: John Hardy
Ramesh A
ui:tag
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 09:46 EST by Ramesh A
Modified: 2017-08-28 11:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-28 11:01:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramesh A 2015-12-29 09:46:44 EST
Description of problem:
Access control element (users, groups) does not honor should honor tag visibility as of now.

Version-Release number of selected component (if applicable):
5.4.4.2.20151130143928_89a28ce

How reproducible:
Very

Steps to Reproduce:
1. Create a new Role and give access to all the Product Features (modules)
2. Create a new group with "My Company Tags"
3. Create new user with the above created group
4. Associate existing Groups/ Users with different "My Company Tags"
6. Login as newly created user and check for the Groups visibility

Actual results:
All the Groups and Users are displayed nevertheless of the Tag restrictions

Expected results:
Should honor Tag visibility

Additional info:
Comment 1 Ramesh A 2015-12-29 09:47:05 EST
This issue is also seen in 5.5.0.13.20151201120956_653c0d4
Comment 4 Chris Pelland 2017-08-28 11:01:36 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.